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1 Introduction 

1.1  Motivation 

Mitigation of natural hazards relies increasingly on numerical process models to predict the area 

inundated by rapid geophysical mass movements. These movements include  

 snow avalanches,  

 torrent based debris flows and hillslope debris flows,  

 mudslides,  

 ice avalanches and glacier lake outbreaks 

 rockfalls and rock avalanches.  

Process models are used by engineers to predict the speed and reach of these hazardous movements 

in complex terrain. The preparation of hazard maps is a primary application. The models are especial-

ly helpful when proposing technical mitigation measures, such as dams and embankments or rockfall 

protection barriers. The models allow hazard engineers to optimize limited financial resources by 

studying the influence of different hazard scenarios on defense options.  

RAMMS was developed by the RAMMS program team at the WSL Institute for Snow and Avalanche 

Research SLF. This manual describes the features of the RAMMS program – allowing beginners to get 

started quickly as well as serving as a reference to expert users. 

The RAMMS web page http://ramms.slf.ch provides useful information such as a moderate discus-

sion forum, frequently asked questions (FAQ) or recent software updates. Please visit this web page 

frequently to stay up to date! 

1.2 RAMMS 

The RAMMS (RApid Mass Movements Simulation) software system contains three process modules: 

 RAMMS::AVALANCHE 

 RAMMS::DEBRISFLOW 

 RAMMS::ROCKFALL 

The RAMMS::AVALANCHE and RAMMS::DEBRISFLOW modules are designed for flow phenomena 

containing fast moving particulate debris of snow and rocks. In the avalanche module, the interstitial 

fluid is air, whereas in the debris flow module the interstitial fluid is mud. The RAMMS::AVALANCHE 

and RAMMS::DEBRISFLOW models are used to calculate the motion of the movement from initiation 

to runout in three-dimensional terrain. The models use depth-averaged equations and predict the 

slope-parallel velocities and flow heights. This information is sufficient for most engineering applica-

tions. Information in the slope-perpendicular direction (e.g. mass and velocity distribution) is lost; 

however, this is seldom of practical interest. Both models require an accurate digital representation 

of the terrain. Engineers specify initial conditions (location and size of the release mass) and friction 

parameters, depending on terrain (e.g. roughness, vegetation) and material (e.g. snow, ice or mud 

content of the debris flow). 

http://ramms.slf.ch/
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The RAMMS::ROCKFALL module is used to study the rigid body motion of falling rocks. The model 

predicts rock trajectories in general three-dimensional terrain. Rock trajectories are governed by the 

interaction between the rock and ground. The model contains six primary state variables: three 

translational speeds and three rotational velocities of the falling rock. From these, kinetic energy, 

runout distance and jump heights can be derived. Generalized rock shapes are modeled. Rock orien-

tation and rotational speed are included in the rock/ground interaction. The RAMMS::ROCKFALL 

module is therefore fundamentally different from the RAMMS::AVALANCHE and 

RAMMS::DEBRISFLOW modules because it is based on hard-contact, rigid-body Lagrangian mechan-

ics, not Eulerian flow mechanics. It also differs from existing rockfall modules because the 

rock/ground interaction is not governed entirely by simple rebound mechanics, but frictional (dissi-

pative) rock/ground interactions. These govern the onset of rock jumping. The RAMMS::ROCKFALL 

module predicts all rigid-body motions – rock sliding, rolling, jumping and skipping. 

In all RAMMS modules, new constitutive models have been developed and implemented, thanks to 

calibration and verification at full scale test sites such as St. Léonard/Walenstadt (rockfall, mitiga-

tion measures), Vallée de la Sionne (snow avalanches) and Illgraben (debris flow). At present, two 

new scientific RAMMS modules are under development: RAMMS::AVAL_EXTENDED and 

RAMMS::DBF_EXTENDED. 

1.3 Learning by doing 

This manual provides an overview of RAMMS::DEBRISFLOW. Exercises exemplify different steps in 

setting up and running a RAMMS simulation especially in Chapter 3 ‘Setting up a simulation’. Howev-

er, to get the most from the manual, we suggest reading it through while simultaneously having the 

RAMMS program open, learning by doing. We assume RAMMS users to have a basic level of familiari-

ty with windows-based programs, commands and general computer terminology. We do not de-

scribe the basics of windows management (such as resizing or minimizing). RAMMS windows, click 

options and input masks are similar to other windows based programs and can be used, closed, 

reduced or resized in the same way. 

 

 

 

DISCLAIMER 

 

RAMMS is intended to be used as a tool to support experienced users. The interpretation of the sim-

ulation results has to be done by a debris flow expert who is familiar with the local as well as with the 

topographic and geological situation of the investigation area. In no event shall SLF/WSL be liable for 

any damage or lost profits arising, directly or indirectly, from the use of RAMMS. Swiss law applies. 

Court of jurisdiction is Davos. If you encounter problems, please contact ramms@slf.ch. 

 

 

mailto:ramms@slf.ch
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2 Installation and Setup 

2.1 System requirements  

We recommend the following minimum system requirements for running 

RAMMS::DEBRISFLOW: 

 Operating Systems: Windows 7, 8 or 10 (64-bit) 

32-bit systems (Win XP) are not supported and recommended anymore 

 RAM (memory): 4 GB (more recommended) 

 CPU:  > 1 GHz, 2 cores or more recommended 

 Disk space: ca. 220 MB needed for the software 

2.2 Installation 

Please download the RAMMS::DEBRISFLOW setup file “ramms_dbf_user_setup_64.zip” from 

http://ramms.slf.ch (Downloads section). We recommend to install RAMMS on a 64-bit Windows 

system (Windows 7/8/10). 

Direct download link: http://ramms.slf.ch/ramms/downloads/ramms_dbf_user_setup_64.zip  

Please do the following steps before beginning to install RAMMS: 

 Click on the path given above or copy the path to any browser. A window pops up and the 
automatic download of the file ramms_dbf_user_setup_64.zip starts after clicking Yes. 

 Unzip the file to a temporary location. 

 You must have Administrator privileges on the target machine. If you do not have such 
privileges, the installer cannot modify the system configuration of the machine and the 
installation will fail. Note that you do not need Administrator privileges to run RAMMS af-
terwards. 

 Read first, install afterwards! Please read the whole installation process once, before you 
begin the installation. 

 Start the file “ramms<version>_dbf_user_setup_64.exe”. 
 

  

http://ramms.slf.ch/
http://ramms.slf.ch/ramms/downloads/ramms_dbf_user_setup_64.zip
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Step 1: Welcome 

The welcome dialog introduces you to the English setup program and will guide you through the 

installation process. Click Next to continue. 

 

Step 2: Readme 

Short introduction to RAMMS. Click Next to continue. 

 

  

 
Figure 2.1: Installation - welcome dialog window. 

 
Figure 2.2: Installation - readme dialog window. 
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Step 3: Accepting the license agreement 

Read the license agreement carefully and accept it by activating the check box in the lower left 

corner. If you do not accept the license agreement, you are not able to proceed with the installa-

tion. After accepting the license agreement, click Next to continue the installation. 

 

Step 4: Select destination directory 

Choose your destination directory. This dialog shows the amount of space available on your hard disk 

and required for the installation. Beware: Do NOT use a blank od special character within your instal-

lation directory path name (e.g. C:\program files\RAMMS is not allowed, use C:\Programme\RAMMS 

or C:\Programs\RAMMS instead). Click Next to start the installation process. 

 
Figure 2.3: Installation - license agreement dialog window. 

 
Figure 2.4: Installation - destination directory dialog window. 
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Step 5: Installing the files 

RAMMS is copying the files to the destination location. The window shows the installation pro-

gress. 

 

 

Step 6: Finished installing the files 

RAMMS finished copying the files. Click Next to finish the installation process. 

 

  

 
Figure 2.5: Installation - installing files dialog window. 

 
Figure 2.6 : Installation - finished installing files dialog window. 
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Step 7: RAMMS installation finished! 

 

RAMMS successfully finished the installation. Click Finish. 

 

Step 8: Welcome to IDL Visual Studio Merge Modules 

To ensure that all important system libraries are installed on your target machine follow the in-

structions below: 

The welcome dialog introduces you to the English setup program and will guide you through the 

installation process of the IDL Visual Studio Merge Modules. Click Next to continue. 

 
Figure 2.7: Installation - finished installation dialog window. 

 
Figure 2.8: IDL Visual Studio Merge Modules - welcome dialog window. 
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Step 9: Ready to install the program 

 

Click Next to continue. 

 

Step 10: Installing IDL Visual Studio Merge Modules 

The wizard is installing the files. Please wait until it is finished. 

 

 

 

  

 
Figure 2.9: IDL Visual Studio Merge Modules - ready to install the program. 

 
Figure 2.10: IDL Visual Studio Merge Modules - installing... 
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Step 11: InstallShield Wizard Completed 

The wizard completed the installation. Click Finish. 

 

After having successfully installed RAMMS and the necessary files on your personal computer, you 

will notice the RAMMS icon on your desktop (for all users): 

 

Additionally, a new application folder is created in Start → Programs (for all users): 

 

 RAMMS → Run RAMMS 

 RAMMS → Uninstall RAMMS 

 

  

 
Figure 2.11: Installation - destination directory dialog window.  

 
Figure 2.12: RAMMS icon. 

 
Figure 2.13: RAMMS program group 
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2.3 Licensing 

Access to RAMMS is controlled by a personal use license. Personal use licenses are time limited li-

censes tied to a single personal computer. This method of licensing requires a machine’s unique 

host ID to be incorporated into a license request file. After the license request file is sent to 

SLF/WSL, you will receive a license key. Entering the license key on a personal computer enables 

full RAMMS functionality for the specific personal computer. For more information please visit 

http://ramms.slf.ch. 

 

2.4 First start 

Double-click the RAMMS icon or use Start → Programs → RAMMS → Run RAMMS to start RAMMS 

for the first time. Whenever you start RAMMS, the splash screen below will pop up: 

 

 

 

Click on the image. It will disappear and RAMMS will start up. The following dialog window appears 

(Fig. 2.15 RAMMS Licensing): 

 

 

 
Figure 2.14: RAMMS start window. 

 
Figure 2.15: RAMMS licensing window 

http://ramms.slf.ch/
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2.4.1 Personal license request file 

Click the button  to create your personal license request file. In Figure 2.16 enter your full 

name and the name of your company. 

 

In the next dialog window, choose the destination directory of your personal license request file and 

save it to your target machine. Your personal license request file should look similar to Figure 2.17. 

 

2.4.2 Getting the personal license key 

You find an order form on the RAMMS web page (Order Form or Demo Order Form) at 

http://ramms.slf.ch. Fill in all your personal information, choose the license period, license type 

and number of licenses you wish to order, attach your personal license request file(s), accept the 

license agreement and click Submit Order. 

An order confirmation email is sent to your email address. We then process your order and send 

you an invoice. As soon as we received your payment, we will send you your personal license key. 

Your personal license key is named similar to  

DBF_20151013_TestName_RAMMS_TimeLicense.txt.  

Open the file in a text editor. It should look similar to Figure 2.18. 

 

 
Figure 2.16: Enter user name and company name. 

 

 
Figure 2.17: Personal license request file RAMMS_DBF_request_TestName.txt 

http://ramms.slf.ch/
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Now, restart RAMMS (as explained before). The IDL splash screen appears (Figure 2.14) and then 

the dialog window of Figure 2.15 shows up (RAMMS - Licensing). Copy the license key (in this 

example: DEBRISFLOW 0h2i-i0ji-ikpm-cjdf-4j4j) and paste it at the field LICENSE KEY (see Figure 

2.15). Notice that there is the prefix DEBRISFLOW. This prefix is part of the license key and has to 

be inserted as well! If RAMMS accepts your installation key, you successfully finished the installa-

tion. 

2.5 Update 

When you start RAMMS it will automatically check for updates on the internet. This can lead to an 

error message, if your firewall blocks the executable idlrt.exe (this file starts the IDL-Virtual Machine 

you need to run RAMMS). Please unblock this file for your firewall. You can also disable the Au-

toWebUpdate-function by unchecking Help → Advanced... → AutoWebUpdate. In the same way you 

can enable the AutoWebUpdate-function by checking Help → Advanced... → AutoWebUpdate. 

 

 
Figure 2.18: Personal license key file RAMMS_license_Muster Test.txt 
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3 Setting up a simulation 

3.1 Preparations 

To successfully start a new RAMMS project, a few important preparations are necessary. Topo-

graphic input data (DEM in ASCII-, XYZ- or GEOTIFF-format), project boundary coordinates and 

georeferenced maps or remote sensing images should be prepared in advance (.tif format and 

.tfw-file, maps and images are not mandatory, but nice to have). Georeferenced datasets have to 

be in the same Cartesian coordinate system (e.g. Swiss CH1903 LV03) as the DEM. Polar coordinate 

systems in degree (e.g. WGS84 Longitude Latitude) are not supported. For more information about 

specific national coordinate systems please contact the national topographic agency in your coun-

try. 

3.1.1 Topographic data - Digital Elevation Model (DEM) 

The topographic data is the most important input requirement. The simulation results depend 

strongly on the resolution and accuracy of the topographic input data. Before you start a simulation, 

make sure all important terrain features are represented in the input DEM. RAMMS is able to 

process the following topographic data: 

 ESRI ASCII grid (Figure 3.1) 

 ASCII X, Y, Z regular, single space data (Figure 3.2, irregular data is not supported!) 

 GEOTIFF (georeferenced information embedded within a TIFF file)  

 
The first two data types are also available e.g. from www.swisstopo.ch. ASCII X, Y, Z data can be con-

verted within RAMMS into an ESRI ASCII grid. Beware, that the XYZ-data must be regular! The header 

of an ESRI ASCII grid must contain the information shown in Figure 3.1. 

Conversion into ESRI ASCII grid 

An ESRI ASCII grid can be created in ArcGIS with the function ArcToolbox → Conversion Tools → 

From Raster → Raster to ASCII. In RAMMS it is possible to import regular ASCII X, Y, Z single space 

data and convert the data into an ESRI ASCII grid (using Track → New... → Convert XYZ to ASCII 

Grid ). 

 
Figure 3.1 : Example ESRI ASCII grid. 

 
Figure 3.2: Example ASCII X, Y, Z single space 

data. 
  

http://www.swisstopo.ch/
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3.1.2 Project and Scenarios 

A project is defined for a region of interest. Within a project, one or more scenarios can be speci-

fied and analyzed. For every scenario, a calculation can be executed. A project consists therefore 

of different scenarios (input files) with different input parameters. The basic topographic input 

data is the same for every scenario. If you want to change the topographic input data (e.g. 

change the input DEM resolution or the project boundary coordinates) you have to create a new 

project. Other input parameters (such as release area, calculation domain, calculation grid resolu-

tion, end time or time step) can be changed for every scenario. 

 

3.1.3 Release information 

In RAMMS::DEBRISFLOW there are two options to define the starting conditions (release infor-

mation) of a simulation: 

 Release area (or block release) 

 Input hydrograph (or simply hydrograph) 

The starting conditions of a simulation can be selected depending on the type of debris flow you 

want to model. Generally, it is useful to distinguish between unchannelized and channelized de-

bris flows. Here we use the term unchannelized debris flow for hillslope debris flows or shallow 

landslides, channelized debris flows develop in regions where torrents limit the flow paths and 

the debris material mainly follows the torrent channel. 

For small unchannelized debris flows it is useful to use a release area with a given initial depth, 

which will be released as a block (block release), while for a channelized debris flow it may be 

more appropriate to use an input hydrograph. The later requires knowledge of the amount of 

material that might flow past a certain location in the channel. Chapter 5 on page 72 includes 

several examples for both types of starting conditions. 

The definitions of release areas and release depths (block release) have a strong impact on the 

simulation results. The same applies for simulations with a hydrograph, where the results are 

sensitive to the discharge hydrograph. Therefore, we recommend to use reference information 

 
Figure 3.3: The same project extent (area of interest) can be used to calculate  

different scenarios with different input parameters. 
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such as photography, GPS measurements or field maps to draw release areas and to use meas-

ured or well-estimated inflow data to define discharge hydrographs. This should be done by peo-

ple with experience concerning the topographic and historical flow situation of the investigation 

area. 

More details on how to create release areas are given in section 3 . 5 . 1 , page 3 4 pp. Details on 

how to use an input hydrograph are given in section 3 .5 .2 , page 37 pp. 

3.1.4 Friction information 

RAMMS employs a Voellmy-fluid friction model, which is based on the Voellmy-fluid approach (we 

refer to Salm et al. 1990 and Salm 1993). 

The choice of the friction parameters requires careful calibration (section 5 . 1 ) of the model by 

using reference information such as field data, photographs of runout zones, estimations or 

measurements of flow velocities and flow heights as well as estimations of the material composi-

tion. This should be done by an persons with expertise in debris flow characterization. 

Physical friction model 

The physical model of RAMMS::Debris Flow uses the Voellmy friction law. This model divides the 

frictional resistance into two parts: a dry-Coulomb type friction (coefficient µ) that scales with the 

normal stress and a velocity-squared drag or viscous-turbulent friction (coefficient ξ). The frictional 

resistance S (Pa) is then 

𝑆 = 𝜇𝑁 +
𝜌𝑔𝒖2

𝜉
   with   𝑁 = 𝜌ℎ gcos(𝜙) 

(3.1) 
 

where ρ is the density, g the gravitational acceleration, φ the slope angle, h the flow height and u 

the vector u = (ux,uy)
T, consisting of the flow velocity in the x- and y-directions. The normal 

stress on the running surface, ρhgcos(φ), can be summarized in a single parameter N. The Voellmy 

model accounts for the resistance of the solid phase (µ is sometimes expressed as the tangent of 

the internal shear angle) and a viscous or turbulent fluid phase (ξ was introduced by Voellmy by 

using hydrodynamic arguments). The friction coefficients are responsible for the behavior of the 

flow. µ dominates when the flow is close to stopping, ξ dominates when the flow is running 

quickly. 

Throughout one simulation, the friction coefficients µ and ξ of a calculation domain are constant. 

However you have the possibility to add up to two polygons within the calculation domain with 

different µ and ξ friction parameters (see exercise 3.5e ”How to run a calculation” on page 47pp.) 

The Voellmy friction model has found wide application in the simulation of mass movements, 

especially snow avalanches. For modeling snow avalanches the Voellmy model has been in use in 

Switzerland for many years and a set of standard parameters is available. 
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Yield stress 

Since Version 1.6.20 the basic Voellmy equation has been modified to include a yield stress (cohe-

sion). Many materials, like mud and snow, do not exhibit a simple linear relation (µ = constant), see 

Figure 3.4. To model yield stress, we introduce the parameter N0. With this approach it is possible to 

model ideal plastic materials. In this case N0 serves as a yield stress and µ a "hardening" parameter. 

The new equation for the frictional resistance S is then 

𝑆 = 𝜇𝑁 +
𝜌𝑔𝒖2

𝜉
+ (1 − 𝜇)𝑁0 − (1 − 𝜇)𝑁0𝑒

−
𝑁

𝑁0  

where N0 is the yield stress of the flowing material. Unlike a standard Mohr-Coulomb type relation 

this formula ensures that S→0 when both N→0 and U→0. It increases the shear stress and therefore 

causes the debris flow to stop earlier, depending on the value of N0 . 

 

 

Curvature 

Since Version 1.6.20, the normal force N includes centrifugal forces arising from the terrain curva-

ture. We use the method proposed by Fischer et al. (2012) which was specifically developed for 

RAMMS. The centrifugal acceleration ƒ is both a function of the flow velocity and terrain curvature. 

The acceleration is calculated according to 

𝑓 = 𝒖𝑲𝒖𝑇 

The matrix K describes the track curvature in all directions, including the track “twist”. The 

centrifugal force is then 

𝐹 = 𝜌ℎ𝑓 

 
 

Figure 3.4: Relation between normal and shear stress. Left: Yield stress N0 serves to increase  
the shear stress for higher normal pressures. At low normal pressures (small flow heights)  

the shear stress increases rapidly from S=0 to S=N0. The slope of the ‘S vs N’ relation remains  
µ, when the normal pressures are large. Right: If µ=0, we have a visco-plasic behaviour. 
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which is added to the normal force N. Typically this increases the friction, causing the flow to slow 

down in tortuous and twisted flow paths. It can change the location of the deposition once the flow 

leaves the gully. Curvature may be activated/deactivated in the Run Simulation window (tab 

Params) or via the menu ‘Help → Advanced… → Curvature’. 

 

Calibration of the friction parameters µ and ξ 

Although the data base for well documented debris flow events is smaller than the one for snow 

avalanches, we have a good idea of the friction parameters which have to be used. The major 

difficulty in case of debris flow simulation is the large variety of debris flow compositions, which has 

a strong influence on the choice of the friction parameters. RAMMS::DEBRISFLOW uses a single-

phase model, so we cannot distinguish between fluid and solid phases and the material is modeled 

as a bulk flow. Therefore, the friction parameters should be varied to match observed flow proper-

ties (for calibrating the model) or expected flow properties (if variation is expected as part of a 

hazard scenario). 

It is common that different events in the same torrent show strong differences in composition. 

This fact makes the calibration of the friction parameters much more difficult and even requires a 

calibration for different events. Therefore, we strongly recommend careful calibration of the fric-

tion parameters by persons with expertise in debris flow characterization. 

The calibration procedure of the Voellmy model is explained with an example in section 5 .1 . 

 

3.1.5 Erosion information 

The erosion module in RAMMS predicts the depth of erosion of sediment caused by debris flows. 

Using this option, it is possible to predict the increase in volume of a debris flow as it travels along a 

channel. By erosion we mean the net decrease in the elevation of the channel bed as a consequence 

of the entrainment of sediment from the bed. Here we provide a brief overview of the erosion mod-

ule and an example of using it. More details can be found in Frank et al. (2015, 2017).  

The erosion module is based on a generalization of field observations from the Illgraben Debris Flow 

observation station in Switzerland, based on repeated terrestrial laser scans by P. Schürch and Alex 

Densmore, of Durham University. The field observations indicate that the depth of erosion increases 

with flow strength e.g. with basal shear stress  (Schürch et al., 2011; Frank et al., 2015) and that the 

rate of erosion can be quite rapid (Berger et al., 2011). Other observations indicate that small debris 

flows do not always erode sediment (Berger et al., 2010, Schürch et al., 2011), so the model includes 

a critical shear stress that permits erosion only when the shear stress in any given cell exceeds the 

critical shear stress value for the onset of erosion c. The erosion algorithm predicts the maximum 

potential depth of erosion em as a function of the computed basal shear stress in each grid cell: 

𝑒𝑚 = 0  for  𝜏 < 𝜏𝑐 
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𝑒𝑚 =
𝑑𝑧

𝑑𝜏
(𝜏 − 𝜏𝑐) for 𝜏 ≥ 𝜏𝑐  

The potential erosion depth (per kPa) dz/d  controls the rate of vertical erosion (in the z-direction) as 

a linear function of channel-bed shear stress.  

The sediment erosion rate in the field (Illgraben channel) was observed using sensors buried in the 

channel bed (Berger et al., 2011) to be 0.025 m/s in the downward direction. Sediment is entrained 

until the erosion depth em is reached: 

𝑑𝑧

𝑑𝑡
=  0.025 for 𝑒𝑡  ≤ 𝑒𝑚 

where et is the depth of erosion (relative to the start of the simulation) at time t and z is the vertical 

coordinate.  

If the shear stress in any given cell is exceeded after erosion takes place, then the maximum depth of 

erosion (relative to the initial bed elevation at the start of the simulation) is automatically adjusted 

and additional erosion can take place until the new value of em is reached. The elevation of the chan-

nel bed does not change during the RAMMS simulation. Users can incorporate changes in topogra-

phy due to erosion or deposition, e.g. for further use in hazard modeling scenarios or event analyses, 

by selecting the post-processing options ‘Results → Add Deposition to DEM’ or ‘Results → Subtract 

Erosion from DEM’ or both with ‘Results → Add Topographic Changes (Erosion/Deposition) to DEM’. 

3.1.6 Calculation parameters 

Calculation parameters, such as output name, simulation grid resolution, simulation (end) time, 

time step etc. can be changed interactively in the RAMMS Run Simulation window. 
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3.2 Preferences 

To ease the file handling we recommend setting the preferences prior to start with simulations. The 

preferences set the path to the working directory and the necessary files such as DEM, maps and 

orthophotos. If the path to the maps and the imagery files is set correctly in the preferences, RAMMS 

will automatically open the georeferenced data when you generate a new project. 

Use Track → Preferences to open the RAMMS preferences window or click the button . For 

resetting the general preferences use Help → Advanced… → Reset General Preferences. 

 

General Tab 

Setting Purpose 

Working Directory Set your working directory. VERY IMPORTANT: DO NOT USE BLANKS 
in the working directory path! 

Map Directory Set the folder where you place your georeferenced digital maps 
(consists of a .tif file and a corresponding .tfw file (world-file). 

Orthophoto Directory Set the folder where you place your digital georeferenced orthopho-
tos (aerial picture, consists of a .tif file and a corresponding .tfw file 
(world-file).  

DEM Directory Set the folder where you place the Digital Elevation Models (format 
ASCII grid)  

 

Debris flow Tab 

Setting Purpose 

Read timesteps Choose between reading ALL or only 1 timestep. 
Default is reading ALL timesteps. 

Nr of colorbar colors Set default nr of colorbar colors. 

GIF-Animation Interval [s] Set interval for GIF animation images in seconds. 

Background Color Set background color (greyscale between 0:black and 255:white). 

Animation Delay [s] Set animation delay to decelerate the animation speed. 

 
Figure 3.5: General tab of RAMMS 

preferences. 

 
Figure 3.6: Debris Flow tab of RAMMS 

preferences. 
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The following exercise Working directory shows how to choose a new working directory. All further 

settings can be changed in a similar manner. The settings are saved, until they are changed again 

manually.  

 

Exercise 3.2 : Working directory 

 

Choosing the right working directory is very useful and saves a lot of time searching for files and 

folders. 

 

VERY IMPORTANT: Do NOT use blanks or special characters in the path names! 

 

 Click  (or use Track → Preferences or Ctrl+P) to open the RAMMS preferences window. 

 Click into the field Working directory. A window pops up where you can choose your new 

working directory. Click OK in both windows. Do this also for other directories if necessary. 

 

 

Figure 3.7: RAMMS preferences 

 

Figure 3.8: Browse for the correct folder. 
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3.3 Creating a new project 

A new project is created with the RAMMS Project Wizard, shown in the exercise below. The Wiz-

ard consists of four steps: 

Exercise 3.3: How to create a new project 

 

 Click  or Track → New... → Project Wizard to open the RAMMS Project Wizard. 

 The following window pops up. 

 

 
Figure 3.9: RAMMS Project Wizard Step 1 of 4 
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Continuation of exercise 3.3: How to create a new project 

 

Step 1:  

 Enter a project name (1) 

 Add project details (2) 

 The project location (3) suggested is the current working directory. To change the location 

click into the Location field. A second window appears and you can browse for a different 

folder (see figure below) 

VERY IMPORTANT: Do NOT use BLANKS or special characters in the project location path! 

 Click Next (4) 

 

 
Figure 3.10: Step 1 of the RAMMS Project 

Wizard Project Information. 

 

 
Figure 3.11: Window to browse for a new 

project location. 

 
Step 2: 

 Click into the Select DEM-file field to 

browse for the DEM file. Locate your 

DEM file in the folder set in the RAMMS 

preferences.  

 The grid resolution of your DEM-file is 

shown in (2). Change the resolution, if 

needed (bilinear interpolation). 

 Click Next. 

 

 
Figure 3.12: Step 2 of the RAMMS Project 

Wizard: GIS Information. 

 
 

  

1 

2 

3 

4 

3 

1 

2 
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Continuation of exercise 3.3: How to create a new project 

 

Step 3:  

 Enter the X- and Y-coordinates of the lower left and upper right corner of your project 
area, using the Swiss Coordinate System CH1903 LV03 (or another Cartesian coordinate sys-
tem), as it is shown below for the Vallée de la Sionne area. 

 RAMMS shows the coordinates of your DEM-file (1). 

 You can clip the DEM by entering new boundary coordinates or by specifying a polygon 
shapefile (2). 

 Click Next (3). 
 

 
Figure 3.13: Project coordinates: lower left and 

upper right corner of project area. 

 
Figure 3.14: Step 3 of the RAMMS Project 

Wizard: Project Boundary Coordinates. 

 
 

 

 

Step 4: 

 Check the project summary. 

 To make changes click Previous, to cre-

ate the project click Create Project. 

 
Figure 3.15: Step 4 of the RAMMS Project 

Wizard: Project Summary. 

 
Project creation: 

 The creation process can take a while. Different status bars will pop up and show the pro-

gress of the project creation process. 

 

 

1 

2 

3 
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The following files will be created in the project folder. 

 

 

File / Folder  Purpose 

doc (folder) Folder containing input and output log files 

logfiles (folder)  Project creation and calculation log files 

dhm.asc  ASCII grid with altitude values 

dhm.sav  Height information used in RAMMS 

_.db2 Input file 

_.dom Calculation domain ASCII file 

_.dom.shp Calculation domain shapefile 

_.dom.shx Calculation domain shapefile 

_.dom.dbf Calculation domain shapefile 

_.xyz Topographic data used in RAMMS 

 

  

 
Figure 3.16: Project files 

Table 3.1: Listing of files and directories created with a new RAMMS::DEBRISFLOW project. 
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3.4 Working with the RAMMS GUI 

Once the project is created, there are several useful tools which can be helpful when working 

with RAMMS. They are explained in the exercises below. 

3.4.1 Visualizing shapefiles and domain-files 

There are different ways to visualize your project files (shapefiles and Domain-files). In the exercise 

below, we will show these possibilities.  

Exercise 3.4a : Visualizing shapefiles and Domain-files 

 
a. Files tab in the right panel: 

 

 Click on the Files tab in the right DEBRIS FLOW panel. 

 In the file tree below, you will see your available project files (polygon and domain shape-
files. 
 

  
Figure 3.17: Files tab and available project files (file-tree, dashed red).  
With the blue + button, files from external directories can be added to  

the file-tree. Refresh the tree with the refresh-button. 

 

 Click the checkbox (left of the filename) and the file will be shown in your visualization. 
 

 
Figure 3.18: Selected file (Blockrelease.shp) on the right is shown in the visualization.  
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 You can select and visualize as many files as you like! 
 

Shapefile Properties 

 Line thickness, color or linestyle can be adjusted for every individual shapefile. Right-click on 
a filename and choose Shapefile properties: 
 

 
Figure 3.19: Right-click menus Shapefile properties, Release properties,  

Set as hydrograph and Delete. 

 

 
Figure 3.20: Use Shapefile properties to change line thickness, color or linestyle. 

 
Release Properties 

 Please see section 3.5.1 on page 34 on how to specify release area properties. 
 

Set as hydrograph 

 With this option you tell RAMMS, that this polygon shapefile is a hydrograph release area. 
See section 3.5.2 on 37 for more about hydrographs. 
 

Deposition analysis 

 This function is only available in output mode. See section 4.2.3 on page 63 on how to do a 
deposition analysis. 
 

Delete 

 Delete a file from disk. 
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b. Adding files to the project 
 
You can add files to the visualization using one of these options: 
 

 Add data: Use the button   or the menu ‘GIS – Add data’ to add a shapefile. If this shape-
file is located outside of your project directory, it will be added to the files-tree. 

 

 Add files from folder: Use the button  (Add files from external directory) below the file-
tree to add all the files from an external directory to the file-tree. These files are added dur-
ing this RAMMS session. After you exit and restart RAMMS, you have to add the files again. 
 

 Drag & Drop: see next section. 
 
 
c. Drag & Drop: 
 
It’s possible to Drag & Drop the following files onto the main visualization window: 
 

 Input files (.av2) 

 Output files (.out.gz) 

 MuXi files (.asc) 

 Polygon shapefiles (.shp) 

 Domain shapefiles (.shp) 
 
 
 
 

3.4.2 Changing maps and orthophotos (aerial images) 

It is possible to change the map or orthophotos of a project anytime. Take into account, that the 

corresponding .tfw-file (world-file) has to be in the same folder as the actual map (.tif ). If this is not 

the case, the map will not be found! 

To check which map and orthophoto is currently loaded in the project, open the project input (or 

output) log (Project  Input Log File). Next to MAP / ORTHOPHOTO INFO you will find the location 

and name of the loaded map and orthophoto, respectively. 

Exercise 3.4b : How to add or change maps and orthophotos 

 

d. Add or change a map: 

 Go to Extras → Add/Change Map or click . 

 If more than one map is found, the following window pops up, listing the maps found: 
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Figure 3.21: Window to choose map image. 

 

Information on the image dimensions (x-Dim and y-Dim, pixel) and size (in MB) are pro-

vided and might be a selection criterion. 

 Select the map you wish to add and click Load selected map. 

 

e. Map not found: 

 If the question "No map found, continue search?" appears, you either don’t have an ap-

propriate map, the map-folder directory is not set (o r  wrong) or the map is saved in a dif-

ferent folder. In the second case click Yes and choose the correct folder. A window pops 

up to browse for the correct map location and file. 

 Or click No to cancel search. 

 
 

f. Change remote sensing imagery: 

 Go to Extras →Add/Change Image or click . 
 

 

3.4.3 Moving, resizing, rotating, viewing 

 

Exercise 3.4c: Moving and resizing the model 

 

a. Terrain model has a dimension of 100% or smaller: 

 

 By clicking on the arrow  the model can be moved and resized. 

 

 
Figure 3.22: Active project with lines and corners for resizing. 
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 To move the model without changing size or aspect ratio, move the cursor to the 

model and check if the cursor turns to . Then click and hold the left mouse but-

ton and drag the model to the desired position. 

 To resize the model without changing the aspect ratio, use the mouse wheel to zoom 

in or out. Alternatively, you can resize the model by changing the percentage value in 

the horizontal toolbar .  

 

b. Terrain model has a dimension > 100%: 

 

 All steps explained above are still possible. 

 In addition to this, the white hand right next to the rotation button becomes active as 

well. After clicking on this so-called view pan button , it is also possible to move 
the model. 
 

 

Exercise 3.4d: Rotating the model 

 

After activating the rotation button , the model can be rotated along the rotation axis, 

by moving the cursor directly on one of the axis until the cursor changes from to . Other-

wise a freehand rotation in any direction is possible. 

 
Figure 3.23: Active project with rotation axes. 
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Exercise 3.4e: How to switch between 2D and 3D mode 

 

Click  to switch from 3D to 2D view. This button then changes to  and by clicking again, you 
will return to 3D view. 

 
Figure 3.24: 3D view of example model. 

 
Figure 3.25: 2D view of example model. 

 
In 2D mode you have all possibilities that work for the 3D mode. It works for input files as well as 

for simulations. For the following functions of RAMMS it is necessary to switch from 3D to 2D 

view: 

 

INPUT: 

 Draw new release area  

 Release area formation  

 Crop release area  

 Draw new domain  

 

OUTPUT: 

 Draw new line profile  

 

3.4.4 Colorbar 

As soon as a parameter is shown in the project, the colorbar appears on the right side of the 

main window. It can be turned on and off by clicking on . 

The colorbar can be moved anywhere in the screen (and can get lost). Use Project → Get 

Colorbar to find a lost colorbar. 

Exercise 3.4f: Editing the colorbar 

Changing the minimum and maximum values of the colorbar as well as changing the number 

of colors used is done in the panel DEBRISFLOW (right of the map window) in the tab Display. 
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 Simply type a new value into the respective 

field and hit the return key on the keyboard. 

The display will be refreshed. 

 To view the underlying topography or im-

age, you can change the transparency. 

 ATTENTION 

Values < x.xxx are not displayed! 

The cutoff depends on the min and max val-

ues as well as on the number of colors. Make 

sure that you have the range of values you 

want to display! 

 
Figure 3.26: The Display tab. 

 

 Open the editing window by either choosing 

Edit → Colorbar Properties or clicking  in 

the vertical toolbar.  

 To change the colorbar properties simply click 

into the field you want to change, then click OK.  

 

 Under Edit → Colorbar White Color the text-

color of the colorbar can be changed to white. 

This can be useful when changing the back-

ground color of your project to white Track → 

Preferences → Debris flow Tab → Background 

Color. 

 

 
Figure 3.27: The Colorbar Properties 

window. 
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3.4.5 How to save input files and program settings 

Once a project is created, it is saved under the name and location you entered during step 1 of 

the RAMMS::DEBRISFLOW Project Wizard (see figure 3.9 on page 26). The created input file has 

the ending *.db2. 

The second situation, in which the input file is saved automatically, is when a calculation is start-

ed. The saved input file has the same name as the created output file. 

Exercise 3.4g: How to save input files and program settings manually 

 

a. Input file: 

 In case you want to save the input file manually before running a calculation, go on Track 

→ Save. This is helpful when a release area was loaded but you wish to close the project 

before doing the simulation. 

 If you wish to save a copy of your file under a new name, go to Track → Save 

Copy As or click . 

 A window pops up to choose an old file which should be overwritten or to type in a new 

name, then click Save. 

 
b. Program settings 

 If you have moved and/or or rotated your project for a better view, you can save this po-

sition by going on Extras → Save Active Position. 

 You can now get back to this position anytime by choosing Extras → Reload Position. 

 

Exercise 3.4h : How to open an input file 

 

 Go to Track → Open → Input File,  click  or use  Ctrl+O . 

 A window opens to browse for a debris flow input file (.db2). 

 Click Open after the file name was selected. 

 The project will be opened. 

 Alternatively, you can drag & drop the input file from your windows explorer onto the 
RAMMS GUI. 
 

Exercise 3.4i : How to visualize a shapefile 

 

 To visualize a shapefile go to GIS → Add  data or click  .  

 A window opens to browse for a shapefile (*.shp). 

 Click Open after the file was selected. 

 Alternatively, you can drag & drop the shapefile from your windows explorer onto the 
RAMMS GUI. 
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Exercise 3.4j : How to open an output file/debris flow simulation 

 

 Go to Track → Open... → Debris Flow Simulation,  click  or use  Ctrl+A .  

 A window opens to browse for a debris flow simulation file (*.out.gz) 

 Click OK 

 The simulation will be opened. 

 Alternatively, you can drag & drop the output file from your windows explorer onto the 

RAMMS GUI. 

 

 

3.4.6 About RAMMS 

Some information about the RAMMS installation on your computer is found here: Help → About 

RAMMS. 

 

  

 
Figure 3.28: About RAMMS::DEBRISFLOW 
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3.5 Running a simulation 

To run a calculation or a specific scenario within a newly created project (creating a project see 

section 4.3) it is necessary to  

 define a release area or an input hydrograph,  

 an erosion area (not mandatory), 

 a calculation domain and 

 friction parameters µ and ξ.  

The definition of a smaller calculation domain is especially useful to keep the number of calcula-

tion points as small as possible, that is, it is best to test what the flow path of a simulation will be 

to limit the calculation domain to this extent. The exercises below show you how to create a re-

lease area, how to use an input hydrograph and how to create a calculation domain. A simulation 

also requires a set of friction parameters. Details on the friction model used in RAMMS::Debris Flow 

are given in section 3.1.4. 

3.5.1 Release area 

There are different possibilities to include a release area into the project. The following table gives an 

overview of the possibilities RAMMS offers. For further explanations see the exercises below. 

Create a new release area 

(exercise 3.5a) 

If there is no release area available for your pro-

ject, or you wish to create a new one, switch to 

2D mode and click  (Draw new polygon shape-

file) 

Open an existing polygon shapefile   

(exercise 3.5b) 

Use the file-tree in the right-hand panel (Files) 

and click the shapefile you want to visualize. Or, 

use the ‘Add data’ button  or menu to visual-

ize a shapefile from another source. 

 

Exercise 3.5a : How to create a new release area (polygon shapefile) 

 

 Switch to 2D mode by clicking .  

 Activate the project by clicking on the map once. 

 Click   (Draw new polygon shapefile).  

 Click into the project where you want to start drawing the outline of the release poly-

gon. 

 Continue drawing the release polygon by moving the cursor and clicking the left mouse 

button. 

 To end the release polygon, click the right mouse button. The polygon will be closed au-

tomatically. 
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Figure 3.29: Project with emerging release area. 

 

Before the release area is created, you have to answer a few questions: 

 

 Add more polygon areas? 

You can either answer with Yes and create a second release polygon as explained 

above or answer with No and continue with the next step. 

 Choose a new polygon shapefile name: 

Enter a new name for the polygon area(s). The ending .shp is added automatically. 

 

The polygon shapefile will now be created and opened directly. The colorbar is not yet shown, 

because you have to define a release depth first (in case of a block release, see next exercise), 

or you have to define the polygon area as a hydrograph area (see exercise 3.5c, no colorbar 

needed). 

 
 

Exercise 3.5b : How to open an existing release area (polygon shapefile) 

 

 Use the file-tree in the right-hand panel (Files) and click the shapefile you want to visu-
alize (see chapter 3.4.1.). 

 Alternatively, you can use the Add data button  or menu ‘GIS → Add data’ to add a 
shapefile from another source than your project directory to your visualization.  

 
 

Once a polygon area is created or opened, you can specify the release depth (in case of a block re-

lease). Switch to 2D mode, choose Input → Release area... → Details/Edit release area , click the 

button  or right-click the polygon shapefile in the Files-Tab and choose Release properties, and 

choose the release area polygon by selecting it with the left mouse button. The appearing window 

yields information about release area, mean slope angle, mean altitude and estimated release vol-

ume. And, most importantly, the release depth can be entered, see exercise below. 

Additional release information is found in the Debris Flow panel, tab Volumes (Figure 3.30 and Figure 

3.31) below. 
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Figure 3.30 : Block release area and volume 

information. 

 
Figure 3.31: Hydrograph area and volume 

information. 
  

Exercise 3.5b : Specify release depth and view release information (block release) 

 

 Switch to 2D mode by clicking .  

 Activate the project by clicking on the topography once. 

 Click on the View/Edit release area button  (in the horizontal toolbar or in the vol-

umes tab in the panel), choose Input → Release area... → Details/Edit release area or 

right-click the shapefile in the Files tab and select Release properties.  

 Then click on the release area you want to get information on. A red polygon is drawn 

around the selected release area. The following window appears: 

 
Figure 3.32 Release area information window. 
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 To change the release depth enter a new value (the resulting release volume is direct-
ly adjusted). Click OK if you want to keep the changes, Cancel otherwise. 
 

3.5.2 Input hydrograph 

To simulate channelized debris flows it is advantageous to use an input hydrograph. However, this 

requires knowledge of the amount of material (discharge) that flows past at a given location. For a 

RAMMS simulation with a hydrograph you have two options. Either you know the discharge at dif-

ferent times at a given location, e.g. estimated by measured flow heights and corresponding channel 

cross sections, or you use the estimated total volume in combination with empirical relationships 

between total volume and maximum discharge (e.g. Rickenmann et al. 1999). 

 
Field measurement of debris flow properties is beyond the scope of this handbook, however if debris 

flow activity in a catchment is frequent, it may be possible to obtain additional information for cali-

brating RAMMS by installing a monitoring station. Many debris flows, when the monitoring data are 

simplified, have a relatively simple triangular wave-like shape (Figure 3.33). Assuming a well-

estimated total volume (e.g. field data), maximum debris flow discharge (Q) and corresponding time 

(t1), as well as the end time (t2) can be calculated. We call this a three-point hydrograph calculation. 

 

In nature, discharge hydrographs are generally better described by four points (Figure 3.34 and Fig-

ure 3.35). However, a three-point hydrograph results in slightly larger flow heights and flow velocities 

after the maximum discharge. If the detailed discharge hydrograph is not known it is useful to choose 

a three-point hydrograph. In critical applications we encourage users to evaluate the sensitivity of 

the model results to the shape of the input hydrograph, e.g. when preparing different scenarios as a 

basis for hazard maps. 

 
Figure 3.33: Three-point hydrograph with total volume of debris flow. 
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Input data for a discharge hydrograph 

In RAMMS::Debris Flow one has the option to enter up to 10 points to define an input hydrograph. It 

requires discharge Q, time t and velocity v at different times. A three-point hydrograph for the event 

shown in Figs. 4.24 and 4.25 might look as following: 

 
Figure 3.34: Four-point hydrograph for discharge values of an event,  

August 2, 2005, at Illgraben,Valais, Switzerland. 

 

 
Figure 3.35: Comparison of a three-point with a four-point hydrograph  

for the given discharge data with the same total volume. 
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 Time t [s] Discharge Q [m
3
/s] Velocity v [m/s] 

Point 0 0 0 6 

Point 1 2.2 8.8 6 

Point 2 1500 0 3 

 

The other option is to define total volume Vtot, corresponding maximum discharge Qmax and time 

when the maximum discharge occurs tmax. The time of maximum discharge is typically observed just 

upslope of the leading edge of the flow, probably on the order of a few seconds to perhaps a few 

10’s of seconds after the arrival of a debris flow at any given location. This allows the calculation of 

the time at which the total volume passed the hydrograph location (tend). Discharge is linearly inter-

polated between known Q-values. 

In both cases, the inflow direction has to be defined, which is described as the angle in counter-

clockwise direction from the x-coordinate of the topographic data (Figure 3.37). 

Table 3.2: Data for discharge hydrograph. 

 
Figure 3.36: Edit hydrograph table. The checkbox (red rectangle) must  

be set to be able to edit the hydrograph table. 
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Exercise 3.5c: How to use the input hydrograph 

 

Hydrograph location and calculation domain 

 Draw a polygon area which extends over the potential debris flow width with the ‘Draw new 

polygon shapefile’ tool (see section 3.5.1) where you want to place the input hydrograph 

(Figure 3.50). Be sure your release area covers several grid cells. The input will initially flow 

downhill perpendicular to the line. Name your release area accordingly. 

 Right-click your release area shapefile and choose Set as hydrograph. 

 

 
Figure 3.38: Beam shaped polygon area (red rectangle) for the input hydrograph inside the 

calculation domain (green line). 
 

  

 Draw a calculation domain (see section 3.5.4), such that the area of the input hydrograph is 

 
Figure 3.37: Definition of inflow direction of an input hydrograph. 
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located inside the domain 

 

Enter data of discharge hydrograph 

 Once you start to RUN a calculation (see section 3.5.4) you can enter the discharge hydro-

graph information in the corresponding tab Hydrograph. For details on how to enter the hy-

drograph data see beginning of this section 3.5.2. 

 
 

3.5.3 Erosion 

To include one or several erosion areas in the simulation, do the following: 

 Draw polygon shapefiles for varying erosion areas. Use Input → Polygon shapefile → Draw 

New Polygon Shapefile to do this. 

 Open the Run Simulation window, change to the Erosion Tab and start to enter the erosion 

characteristics. 

1. Select shapefile 

2. Choose/select parameters, see Table 3.3 below for details. 

3. Click the + button to add your selection to the Erosion Shapefile List. 

 

…do the same for every shapefile you want to use. 

 
Figure 3.39: Erosion Tab 
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Erosion Parameters 

Erosion density: 
(kg/m3) 

We suggest to use the default density (or the density that you selected in 
the Params tab) unless you have more detailed information. 
 

Erosion rate: 
(m/s, default 0.025) 

The rate at which debris flows entrain material from the sediment bed. 
There are very few values available from the field (see Frank et al.), so we 
propose using a constant value based on the work published by Berger et 
al., 2011 (0.025 m/s), for the Illgraben torrent (erosion rates measured us-
ing sensors buried in the channel bed). This is a rate that the model will use 
for entrainment until the predicted erosion depth is reached. Increasing  
this value will cause sediment to be entrained at a faster rate, potentially 
resulting in relatively large debris flow snouts. 
 

Pot. erosion depth: 
(per kPa, default 0.1) 

This parameter controls the maximum potential erosion depth (variable em 
in the paper by Frank et al.) as a function of the maximum shear stress 
reached in each cell. This value actually is the slope of the line which relates 
em to the maximum shear stress calculated for each cell. By changing the 
value of this parameter to e.g. 0.2 (menu choice deep) you will double the 
maximum potential erosion depth. 
 

Critical shear stress: 
(kPa, default 1.0) 

This is the value at which erosion can start occurring. It might be reasonable 
to expect that a channel bed consisting of interlocked boulders would have 
a larger critical shear stress, while a channel bed of saturated sandy gravel 
would have a lower value. Our value is just a curve fit to the data reported 
by Schürch et al. (2011). 
 

Max erosion depth: 
(m) 

Here we can set a maximum thickness of the layer of erodible sediment if 
such data are available (e.g. in some cases we may know that there is only a 
limited amount of sediment available). 

 

 

 

Table 3.3: Parameters for erosion areas. 
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3.5.4 Calculation Domain 

To reduce calculation time you can specify a smaller calculation domain to reduce the number of 

computational cells. By analyzing a calculation with a coarse grid (large cell size), e.g. with a cell size 

of 5 or 10 m, you get an idea where the flow path is situated and you can limit the calculation domain 

to the area of interest.  

Switch to 2D mode and choose Input → Calculation Domain... → Draw New Domain or click . 

Now you can draw a polygon containing the area of interest similar to drawing a new polygon area 

(see exercise "Create release area" on page 34). We strongly recommend using smaller calculation 

domains especially if you calculate with small cell sizes (e.g. < 5m). 

 

Exercise 3.5d : Finding an optimized calculation domain 

 

 Open your input file. 

 Draw a rough calculation domain as explained above, see Figure 3.41 below. 
 

 
Figure 3.40: Calculation domain in green encloses the area of interest and reduces calculation 

time incomparison with the default rectangular domain which is automatically generated. 
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Figure 3.41: Input file with a rough calculation domain 

 

 Do a rough calculation with a simulation resolution of 4m (instead of 2m, e.g.). 

 Wait for the simulation to finish. The simulation result will be displayed. 

 Click the Max Flow Height button . 
 

 
Figure 3.42: Max Flow Height of a 4m simulation 

 

 Click GIS  Export…  Create Envelope Shapefile 

 Question: Use buffer? 

 Click Yes. We want to use the envelope shapefile as a calculation domain, and therefore 
we want to buffer it a little bit (click No if you want to have the exact envelope). 

 Choose a filename for the envelope shapefile (a name is proposed). 

 The created envelope shapefile is shown in the visualization as a dashed red line. 
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Figure 3.43: Envelope shapefile (dashed red line) of Max Flow Height extent 

 

 Switch back to the input file   

 Use Input  Calculation Domain…  Load Existing Domain to load your envelope 
shapefile as a new calculation domain, see Figure 3.44 below. 

 

 
Figure 3.44: Input file with optimized calculation domain (envelope shapefile) 

 

 Now redo your simulation with a simulation resolution of 2m.  
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Figure 3.45: Max Flow Height result of a 2m simulation 

 

 In this example, the much smaller new calculation domain saves 50% !!!!! of the 
computational time. 
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3.5.5 How to run a calculation 

To run a calculation you have to open a created project (section 3.3), load a release area (section 

3.5.1), and draw a calculation domain (section 3.5.4). Below you find an example for running a calcu-

lation with constant release height and constant friction parameters µ and ξ. 

Exercise 3.5e: How to run a calculation 

 To run a simulation choose Run → Run Calculation or click  

 The RAMMS | Run Simulation window opens. Before clicking Run Simulation, you should 

check the input parameters. 

 

General Tab: 

 

(1) Output Name: Choose a good output 

filename, add parameter information to 

the filename to recognize the output file.  

 

(2) Project name: 

 

(3) Details: Add valuable project information 

to this field.  

 

(4) Additional information: Calculation do-

main file and digital elevation model 

(DEM). 

 
(5) Stop Parameter: The stopping criteria in 

RAMMS is based on the momentum, see 

section 4.2.5 on page 65. 

 
(6) Remarks: “Escape” and “Ctrl+R” can be 

used to cancel resp. start a simulation. 
 

(7) Check box Run in background: Option to 

run simulations in background mode. 

The RAMMS interface remains active and 

allows the user to start e.g. new simula-

tions. 

 
 

 
Figure 3.46 General Information 

 
  

1 

2 

3 

4 

7 

5 

6 



CHAPTER 3 : SETTING UP A SIMULATION 

48 

 

Continuation of exercise 3.5e: How to run a simulation 

 
Params Tab 

 

(1) Simulation Parameters 

 Sim resolution: Change, if necessary. The 

resolution should always be chosen so 

that important features of the terrain 

are represented in the terrain model. 

High resolution grids will extend your 

calculation time. 

 End time: Choose simulation end time.  

 Dump-step: The dump-step interval de-

fines the resolution of the animation of 

your simulation but has no effect on the 

simulation results. 

 Density: Keep the default value for den-

sity if no further information on the de-

bris flow material is available (2000 

kg/m3). 

 Lambda: Keep the default value for the 

earth-pressure coefficient Lambda (1.0). 

The parameter Lambda modifies the 

longitudinal pressure gradients driving 

the flow.  

 

  
Figure 3.47: Parameter Tab 

 

The default Lambda value of 1.0 disables the effect of Lambda. The use of Lambda other than 

1.0 is only possible in 1st order numerical solver and will influence the simulation results. Re-

sults with a Lambda other than 1.0 have to be checked carefully and are not recommended. 

 
(2) Numerical Parameters 

 Numerical Scheme: Change numerical solver, 1st or 2nd order scheme. We recommend using 

2nd order, because it provides more accurate solutions than 1st order. However if you en-

counter stability problems it may be useful to run your calculation using the 1st order numer-

ical scheme 

 Keep the default value for the Null-height H cutoff (0.000001 m). Unrealistic shallow flow 

heights of the simulation are eliminated to minimize numerical errors. 

 
(3) Miscellaneous Parameters 

 Obstacle/Dam File: Draw polygons of areas, where no flow should pass (houses, deflecting 
dams, obstacles). The flow is deflected. 

 Curvature: Switch Curvature on or off. 

1 

2 
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Continuation of exercise 3.5e: How to run a simulation 

 
MuXi Tab 

 

(1) Enter the friction parameters μ and . Start 

first scenario simulation with default values 

(μ = 0.2,  = 200 m/s2). More information on 

frictional resistance is given in sections 3.1.4 

and 5.1. 

 

(2) Check box Define Additional MuXi Areas: if 

you want to add polygon regions with dif-

ferent μ and  values. e.g. to represent sig-

nificant changes in the channel, heavily for-

ested areas or perhaps smooth roads. Load 

the corresponding polygon shapefiles and 

define μ and  for up to two additional re-

gions. Be very careful in using this feature! 

 
(3) Yield Stress: Define a polygon area where 

you want to use an additional yield stress 

(cohesion). Specify a yield stress in the Yield 

stress (Pa) field. See section 3.1.4 on page 15 

for more details about yield stress. 

 
 
 
 
 
 
 

 

  
Figure 3.48: MuXi Tab 
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Continuation of exercise 3.5e: How to run a simulation – Hydrograph/Block release 

 

(1) Use BLOCK release (Check box): As an alter-

native to a simulation with a hydrograph. 

(2) Hydrograph Help 

(3) Hydrograph/Release Shapefile(s): Release 

shapefile(s). If more than one shapefile is 

specified, a  button is shown. A tooltip 

will show the additional shapefile names 

when moving the mouse over the button. 

(4) Inflow direction (degrees): Define the inflow 

direction of the debris flow at the hydro-

graph input location. Click the info button 

for a detailed description of inflow direction. 

(5) 3-Point Hydrograph Calculation: Define a 

discharge hydrograph by entering total vol-

ume V (maximum discharge Qmax is calculat-

ed automatically according to Rickenmann, 

1999), corresponding time at which the 

maximum occurs (tmax) and velocity v. End 

time (tend) of the input hydrograph is auto-

matically calculated. 

(6) Edit hydrograph table (Check box): Activates 

the table (7) and is an alternative to a 3-

Point Hydrograph Calculation (5). 

 
   

Figure 3.49: Hydrograph Tab 

 

Release - Hydrograph Tab 

The default RELEASE mechanism for debris flows is a HYDROGRAPH! 
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Release - Block Release Tab 

 

(1) Use BLOCK release (Check box): Click this 
checkbox to do a block release simulation. 

(2) Block Release Help 
(3) Subtract release height from DEM (Check 

box): Subtracts the release height from the 
DEM and uses a new DEM for the calcula-
tion. 

(4) Shapefile and Volume Information: Over-
view of all used release areas with volume, 
depths and delays, as well as the total re-
lease volume. 

 
 

  
Figure 3.50: Hydrograph Tab 
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(1) Erosion Shapefile: Specify your erosion 
shapefile area. 

(2) Erosion Parameters: Specify erosion param-
eters. Use dropdown menus to select pa-
rameter values. See section 3.5.3 on page 41 
for more details about erosion parameters. 

(3) Add to list button: Click the button to add 
your erosion shapefile and parameters to 
your erosion list. 

(4) Erosion shapefile list: List of erosion shape-
files and parameters. You can delete single 
entries or the whole list with the buttons 
Delete and Clear List. 

(5) Run Simulation Button 
 

  
Figure 3.51: Erosion Tab 

  

Continuation of exercise 3.5e: How to run a simulation – Erosion 

 

 

Erosion Tab 
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Continuation of exercise 3.5e: How to run a simulation – Start Simulation 

 

 Click run simulation (Figure 3.51) 

 If you want to start multiple simulations automatically (e.g. overnight) use Track → New… → 

Run Batch Simulations. You can choose how many computational cores the Batch-Mode 

should use. 

 The following window appears, showing the status of the calculation (Figure 3.52) 

(1) General information of the simulation, (2) output file, (3) starting the calculation (4) for 

every time step RAMMS calculates the maximal values (height, velocity and pressure) as well 

as the outflow mass, the moving momentum and the flow volume. 

 

 
Figure 3.52: Standard output log window. 

 

 
Figure 3. 53: Background simulation mode window.  

Press any button to close the DOS window. 
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4 Results 

Once the simulation is finished, the simulation as well as the output logfile (see Figure 4.3) are 

opened in RAMMS (if you ran the simulation in background mode, see Figure 3. 53, click any button 

inside the DOS window to close the window. Afterwards, open the simulation in RAMMS manually). 

If mass flows out of the calculation domain, RAMMS shows an alert (Figure 4.2). To get reliable re-

sults you should enlarge your calculation domain (see section 3.5.4). 

 
Figure 4.1: Main window in output mode. 

 

 
Figure 4.2: Outflow volume alert. 
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4.1 Project information 

Once a scenario within a specific project is calculated it is possible to open the output logfile (in out-

put mode) including project settings and information as well as calculation specifications. You can 

open the project’s output log with Project →Output Log File. A window as shown in Figure 4.3 opens. 

This window provides information about your project and is the first thing to look at after running a 

simulation to check your simula-

tion results. 

(1) Information on simulation 

time and resolution. Be 

sure the simulation 

stopped due to LOW FLUX. 

Otherwise the output 

TIME END CONDITION in-

forms you, that your simu-

lation stopped before the 

debris flow reached the 

stopping criteria you de-

fined for the simulation 

(see section 4.2.5 on page 

65). 

 

(2) Information on simulation 

results. 

 

(3) Input logfile (see Figure 

4.4). 

  

 
Figure 4.3: Output Logfile. 
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The input logfile (included in the output logfile), however, can already be opened once a project is 

created and before a simulation is performed. 

There are two ways to view your project settings and information. First you can open your project’s 

input logfile (or output logfile, in output mode), or you can check your project’s region extent and 

area in the debris flow panel in the region tab. 

 

 

You can open the project’s input log file with Project → 

Input Log File. The following window opens: 

This window provides information about all your project’s 

input specifications, like number of nodes and cells, re-

lease areas, which DTM was used, the loaded map and 

orthophotos as well as your global simulation parameters. 

 

 

 

 

 

 

 

To view the project coordinates, click the region 

tab in your debris flow panel. The region tab lists 

X- and Y-Coordinates of the lower left (minimal 

values) and upper right (maximal values) corner 

(these are coordinates you entered when creat-

ing the project) as well as the global minimum 

and maximum altitude (Z value). Additionally, 

the total region area is shown (in km2). 

 

  

 
Figure 4.4: RAMMS Project Input Log 

file. 

 

 
Figure 4.5: Region extent (X-, Y- and Z-

Coordinates, total area). 
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4.2 Visualization and analysis of the results 

This section gives a short overview on what is possible in RAMMS to view and analyze the simulation 

results. The interpretation of the results has to be done by an expert who is familiar with the local as 

well as with the topographic and meteorological situation of the investigation area. 

RAMMS is a model and each model is a simplification of reality, therefore the simulation results 

should not be analyzed without questioning them. We strongly recommend that all users perform 

sensitivity studies. 

 

4.2.1 Visualize different parameters 

The drop down menu Results offers the following functions: 

 Flow Height 

 Flow Velocity 

 Flow Pressure 

 Flow Momentum 

 Erosion 

 Max values (Height , Velocity , Pressure , Momentum, Shear Stress, Erosion) 

 DEM Adaptions (Add Deposition to DEM) 

 Flow Analysis (Summary of Moving Mass) 

 Friction Values (µ, ξ) 

These results are all visualized in the topography. See exercise “Displaying calculation values” below. 
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Exercise 4.2a: Displaying calculation values 

The maximum values of flow height, velocity and pressure give a good overview of the dimension of 

the debris flow. You find them under 

Results → Max values… 

 

 Max flow height  

 Max velocity  

 Max pressure  
 

 

 
Figure 4.6: Results: Maximum values of flow height (left), velocity (middle) and pressure (right) 

 
 
The flow height can be visualized exaggerated by a factor. Click Help → Advanced… →Additional 

Preferences… →Edit to change the factor of the quasi 3D-visualization of the flow height under the 

keyword exaggeration. 

 

 
Figure 4.7: Quasi 3D-Visualization of flow height (left: exaggeration 1; right: exaggeration 5). 
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4.2.2 Line profile plot and time plot 

In the horizontal toolbar you find two further functions: 

 Line Profile  

 Time Plot  

 

Line profile plot 

A line profile is a good analysis tool, if the flow height, velocity or pressure should be known at a spe-

cific location. The graph shows the currently active parameter. Every line profile is saved in the file 

profile.shp in the project directory. If you want to keep this line profile, you have to save it, see exer-

cise “How to draw a line profile” below. 

 

Time plot 

This function provides a time plot at a single point. This is helpful when it is of interest to know the 

values and maximum values at a specific location (e.g. at a building, dam, or a tree) through time. 

Every point is saved in the file point.shp and a point-info file point_info.txt is additionally saved in the 

project directory. If you want to keep this point, you have to save it, see exercise “How to create a 

time plot” below. The point-info file can be visualized with Extras → Point… → View Point Info File. 

 

Flow discharge 

From version 1.7.0 on it is possible to calculate the flow discharge when drawing a line profile (cross 

profile). See line profile exercise below.  
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Exercise 4.2b: How to draw a line profile 

a)  Draw a new line profile: 

 Switch to 2D mode by clicking   

 Activate the project by clicking on it once, then click  or choose Extras → Profile → Draw 

New Line Profile 

 Define the line profile in the same way you specify a new release area. Finish the line profile 

with a right-mouse click. 

 Calculate flow discharge? Answer with YES, and the flow discharge is calculated and shown in 

the line profile plot, see below (Beware: this can be time consuming!). 

 A window opens, displaying the line profile. 

 

 
Figure 4.8: Line profile plot, with calculated flow discharge. 

 

 

 Filled grey area        active parameter (scale on left side). 

 Red line                     active parameter (multiplied by 50) added to the track 

                                   profile (altitude, scale on the right side). 

 Black line                  track profile (altitude, scale on the right side). 

 Bottom scale            projected profile distance (in m). 

 

 If you change the active parameter, min or max values or the dump-step in RAMMS, the plot 

is directly updated. You can also start the simulation and then watch the time variations in 

your line profile plot. 

 It makes sense to either draw a profile line perpendicular to the flow direction or draw the 

line along the flow path. Basically every imaginable path is possible 
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Continuation of exercise 4.2b: How to draw a line profile 

 

 

 

Figure 4.9: Line profile perpendicular to debris 
flow direction. 

Figure 4.10: Line profile along the debris flow 
direction. 

 

 

 To save the coordinates of the points belonging to the line profile, go on Extras → Profile → Save 

Line Profile Points and enter a file name. 

 To save the line profile parameters (distance in m and the active parameter, e.g. the flow height in 

m) at the current dump-step, go on Extras → Profile → Export Profile Plot Data and enter a file 

name. 

 
 

  



CHAPTER 4 : RESULTS 

62 

 

Continuation of exercise 4.2b: How to draw a line profile 

b) Load an existing line profile: 

 Switch to 2D view by clicking  

 Activate the project by clicking on it once and click  or choose Extras → Profile → Draw 

New Line Profile 

 Click the middle mouse button once 

 A window pops up and you can browse for the line profile you wish to open 

 

Exercise 4.2c: How to create a time plot 

a)  Select time plot point: 

 Click  or choose Extras → Point → Choose Point 

 Click into the map at the point where you want to create a time plot. 

 A window opens, displaying the time plot at the point of interest (active parameter vs. time). 

 

 

 To save the point coordinates, choose Extras → Point → Save point Location and enter a file 

name 

 To save the time plot data (time in s and the active parameter, e.g. the flow height, for every 

dump-step), choose Extras → Point → Export Point Plot Data and enter a file name. 

 

 

 
Figure 4.11: Time plot window. 
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Continuation of exercise 4.2c: How to create a time plot 

b) Load a time plot: 

 To reopen the time plot graph window of the last selected point, go on Extras → Point → 

Create Point Time Plot  

 To open an arbitrary time plot that was saved any time before, click . 

 Click the middle mouse button once. 

 A window pops up and you can browse for the time plot file you wish to open. 

 

c) Enter point coordinates and get a time plot: 

 Go to Extras → Point → Enter Point Coordinates (X/Y)  

 Enter X-coordinates of your point of interest. Click OK. 

 Enter Y-coordinates of your point of interest. Click OK. 

 The time plot opens. 

 
 

4.2.3 Deposition analysis 

A deposition analysis (flow height) for a region of interest (ROI) can be done in the following way: 

 right-click the shapefile you want to analyse 

 choose Deposition analysis 

 

 
Figure 4.12: Deposition analysis of region of interest. 
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4.2.4 Creating an image or a GIF animation 

Image 

It is possible to export your results as an image in different formats (e.g. .png, .jpg, .gif, .tif etc.). 

Click  or choose Track → Export… → Image File and define a file name with the corresponding 

extension. An image of the visible part in the viewer will then be exported. 

 

GIF animation 

Creating a GIF animation is only possible in output mode. Click  or choose Track → Export... → GIF 

Animation. Enter a file name and location and wait until the simulation stopped. As soon as the sim-

ulation finished, the GIF animation file is saved. In the Preferences (debris flow tab) you can define 

the interval for the GIF animation (GIF animation interval [s]). 

  

 
Figure 4.13: Result of a deposition analysis. Total deposition volume (m

3
)  

as well as some statistical values are shown (min, mean, max). 
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4.2.5 Stopping mechanism 

Check the output logfile under Project → Output Logfile to verify your simulation stopped due to low 

flux (see Output Logfile on page 51).Otherwise enlarge the end time of your simulation (see exercise 

“Run a calculation” on page 45). To check the stopping of your simulation click Results → Summary 

of Moving Mass. A window similar to Fig. 4.12 opens which shows the summary of moving mass. For 

every dump-step, RAMMS summed up the momenta of all grid cells, and compared it with the maxi-

mum momentum sum. If this percentage is smaller than a user defined threshold value (see page 

48), RAMMS aborts the simulation and the debris flow is regarded as stopped. 

 

The stopping criteria in RAMMS is 

based on the momentum. In clas-

sical mechanics, momentum p (SI 

unit kgm/s, or, equivalently, Ns) is 

the product of the mass and ve-

locity of an object (p = mv). 

Threshold values between 1-10% 

are reasonable, but this is only a 

suggestion and has to be empiri-

cally determined for each test 

case. 

Stopping criteria with large 

threshold values (e.g. >10%) may 

result in unrealistic early stopping 

of a simulation. 

Small threshold values however 

may lead to numerical diffusion of 

the simulation results and very 

slow creeping of the debris flow 

material and velocity oscillations. 

 

 

 

 

 

 

 

 
 

 
Figure 4.14: Summary of moving mass. 
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Because block release simulations (the entire debris flow material starts to flow at the same time) 

usually show larger values for the total maximum momentum than hydrograph simulations (con-

trolled inflow of debris flow material into calculation domain), the threshold values for block release 

simulations could be set smaller than the threshold values for hydrograph simulations in some situa-

tions (see Fig. 4.14 and 4.15 and section 5.2). 

Whether or not a flow stops depends on terrain (slope angle in runout), total flow volume and fric-

tion values and should always be evaluated by an expert. In case of doubt on how to choose thresh-

old values we recommend running a simulation with a 1% threshold and checking the summary of 

moving mass for numerical diffusion and analyzing the debris flow runout (flow height and flow ve-

locity) with time plots (section 4.2.2). 

 

 

 

 

 

 

 

 

 

 

Figure 4.15: Stopping behaviour of a RAMMS simulation. Small threshold values may lead to unlikly 
slow creeping of the material. In the example shown in the figure above the stopping  

criteria is set to 0%. 
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Figure 4.16: Stopping behaviour of a hydrograph RAMMS simulation. In this example threshold values 

<5% lead to numerical diffusion of the simulation results. A threshold value of 5% seems to be 
appropriate in this cas. 

 
Figure 4.17: Stopping behaviour of a block release RAMMS simulation. In this example threshold values 

<2% lead to numerical diffusion of the simulation results. A threshold value of 2-3% seems to be 
appropriate in this cas. 
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4.3 Adding structures or deposition to DEM 

The option to adding structures or deposition to DEM must be used with great care and should not 

be used to design deflecting dams. Deflecting or catching dams can neither be designed directly with 

RAMMS nor can the residual risk below dams be calculated directly with RAMMS. RAMMS takes im-

portant factors in dam design such as energy dissipation, dam geometry or debris flow deposits in 

front of a dam not properly into account. Dams have to be designed using well known standard engi-

neering procedures, e.g. Johannesson et al. 2009, Rudolf-Miklau and Sauermoser 2011 and Ricken-

mann 1995. RAMMS is well suited to calculate the key input factors for dam design such as flow 

height and velocity. The dam-option should however only be used to try to visualize the influence of 

guiding or small deflection of the debris flow mass. RAMMS cannot be used directly to evaluate if the 

height of a deflecting dam is sufficient for a certain scenario or not (see explanations below). 

4.3.1 Creating a dam 

RAMMS offers the possibility to simulate the presence of a deflecting dam by increasing the altitude 

at the position where a dam is considered. This option helps the user to design mitigation structures 

and to test its influence on potential flow paths near populated areas. 

Exercise 4.3a: How to create a new DEM to simulate a dam 

 Create a new polygon area where a dam is supposed to be built (Figure 4.18). 

 Create a second, inner polygon, if you wish to have a two-stage dam. 

 Go on GIS  Add DAM to DEM… 

You have two options…  Enter Relative Dam Height or … Enter Dam Elevation 

 You will be asked to “Open dam file (*.shp)”. Select the shapefile you want to use as the out-

er edge of the dam. 

 The question pops up, if you want to “Open 2nd dam shapefile (inner polygon)?” 

 Click No to continue with the next step 

 Click Yes to choose a 2nd dam file (*.shp). 

 Next step is to enter the total elevation height or the total relative height of the dam in me-

ters. This is the elevation of the dam crest. 

 If you loaded an outer polygon file, you will be asked to enter the intermediate height (m) 

(height of the outer polygon file) as well. 

 Finally you have to “Enter new XYZ name”. Your new xyz-file with the topographic infor-

mation, containing the “dam”, is created in your project directory. 
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Figure 4.18: Release area where a dam is 
supposed to be built. 

 
Figure 4.19: Dam. 

 
 

To run a simulation based on the new created xyz-file, all you have to do is to choose the new xyz-file 

in the Run Simulation window, see below: 

 

 

 
Figure 4.20: Select new xyz-file with dam information. 
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While RAMMS is able to simulate the effect of a dam lying lateral to the direction of flow quite well, 

there might occur numerical problems if a dam lies perpendicular to the direction of flow (see Figure 

4.22). 

 Because there is no energy dissipation due to collision with dams implemented in RAMMS, 

unrealistically large flow velocities and flow heights may be simulated in front of a dam. 

 The numerical solver used in RAMMS incorporates information from neighboring cells. The 

effect of dams with only one cell as dam side wall may therefore be difficult to simulate. 

 

 

 

 

 

 
Figure 4.21: Simulation without mitigation measures (left) and with two dams built in RAMMS 

(right). 

 
Figure 4.22: Comparison of the profiles of two mitigation measures in RAMMS. 
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If you encounter problems with the simula-

tion of mitigation measures as described, we 

suggest creating a DEM including a dam in 

GIS, ideally using progressively increasing 

side walls as shown in Figure 4.23.   

 

The interpretation of RAMMS simulations including mitigation measures such as dams (see Figure 

4.22 and Figure 4.23) has to be done by experts. In addition we recommend to always check the sim-

ulation results with engineering approaches. 

 

4.3.2 Creating a new DEM with deposited debris material 

It is possible to simulate multi-surge debris flow events to estimate how deposits from earlier surges 

can influence the flow of subsequent surges. One has to assume that the deposits from an initial 

surge are not entrained by subsequent surges. To do this, in the output mode, users can select the 

option to add the flow height of a debris flow to the DEM at any arbitrary dump-step. Finally, a new 

project can be created based on the updated DEM. 

 

Exercise 4.3b: How to add debris flow deposition to new DEM 

 The deposition height is the flow depth at the end of a simulation when the flow is consid-

ered to have stopped moving (alternatively, earlier dump-steps may be used if there are rea-

sons to believe the flow should have stopped earlier). So first view the results at the last time 

step or a different time step, if desired. 

 Go to Results  DEM Adaptations  Add Deposition to DEM 

 Enter a new name for the new xyz-file.  

 The new xyz-file, containing the deposition information, is created. To run a simulation based 

on this new xyz-file, just choose the xyz-file in the Run Simulation window, see Figure 4.20. 

 
 

 

 
Figure 4.23: Dam with gradually rising side walls. 
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5 Applications 

RAMMS::DEBRISFLOW can be initiated using either a block release (e.g. landslide release) or a hydro-

graph (flow discharge as a function of time). In some cases it may not be entirely clear which method 

is most suited. In this section we describe some practical differences in model results which may 

occur depending on which method is used to start the flow in the model. 

This chapter presents several topics relevant for the application of RAMMS::DEBRISFLOW in practice. 

Several examples of how to use RAMMS to simulate channelized debris flow (flow paths of debris 

flow limited by topography, such as a mountain torrent) using either a block release or an input hy-

drograph are summarized. Model calibration and the question how to calculate model impact pres-

sure are discussed. 

5.1 Calibration 

The following section is based on simulations run in 2011 with RAMMS::DEBRISFLOW v1.4. 

The calibration of the Voellmy friction model is one of the most important steps to get realistic and 

useful results. For the calibration procedures a well-documented historical event is required. The 

historical event should be similar to the problem where calibration is required. Ideally, information 

should include flow heights and velocities at different locations in the torrent as well as the material 

composition, information concerning different flow paths and the initial conditions such as the total 

and the initial volumes. In practice, it is difficult to collect exact data on flow heights and velocities 

from field studies. However, field data can provide estimates of total volume, flow paths, flow 

heights and material composition and sometimes even flow velocities. 

Here, an example is shown , which was used for the calibration of RAMMS::DEBRISFLOW for the spe-

cific case at Dorfbach, close to Rana (VS, CH). See Deubelbeiss and Graf, 2013. The following data was 

used to calibrate the model: 

 

Field investigations  

Cross sectional analysis Heights of levees or heights of marks on constructions, estimation of 
velocity (splashing, superelevation) 

Flow paths Tracks of boulders, rocks and mud 

Deposition of material Lobes, levees and debris flow heads 

Estimation of total volume Retention basin in the runout zone plus deposited material in tor-
rent and receiving river 

Photographs  

Release area Geometry of release area 

Flow Paths Deposited material analyzed by aerial photographs 

 

Table 5.1: Parameters for calibration for the case study of Dorfbach, Randa (CH). 
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Field observations and investigations provided an estimate of a total volume of approximately 10’000 

m3. The aim was to calibrate the model by comparing flow velocities and flow heights at two loca-

tions (Figure 5.1a). The estimated values obtained from the field observations at these locations are: 

 

 Max flow height [m] Velocity [m/s] 

Location 1 2-3 3-4 

Location 2 2-3 1-2 

 

Find the best-fit Voellmy friction coefficients (procedure) 

To find the best- fit Voellmy friction coefficients (dry-Coulomb type friction µ and viscous-turbulent 

friction ξ) we suggest the following calibration procedure: 

1. Define µ which – as a first guess – is set to tan(𝛼) is the slope angle in the deposition zone. 

For the case in Dorfbach we defined 𝜇 ≈ 0.2 (𝛼 ≈ 15°). 
Values of µ normally range between 0.05 and 0.4. Values of µ larger than 0.4 rarely provide 

useful simulation results. 

2. ξ is more delicate to calibrate and we suggest starting with an initial guess of ξ =200 m/s2.  

ξ describes the turbulent behavior of the flow. Typically small values of ξ are reported for 

granular flows while relatively large ξ values are sometimes associated with muddy flows. 

 Granular flow (solid-dominated) Mud flow (fluid-like) 

Viscous-turbulent friction, ξ [m/s2] 100-200 *) 200-1’000 *) 

*These values are only suggestions not fixed definitions. 

 

If the type of flow (granular or muddy) is not known, we suggest the following initial values of the  

Voellmy friction coefficients for the calibration: 

Initial values of the Voellmy friction coefficients 

used for a calibration procedure with unknown 

flow type 

Dry-Coulomb type friction µ [ ] 0.2 

Viscous-turbulent friction ξ [m/s
2
] 200 

 

3. Vary µ around the initial definition with steps of ±1 and ξ with steps of ±100 m/s2. After com-

paring this initial results with field observations, start with a fine tuning and incrementally 

change µ and ξ around the initially-found best-fit values. To match the simulation results 

Table 5.2: Field estimations of height and flow velocity for  
the case study of Dorfbach, Randa (CH). 

Table 5.3: Suggestions for setting the viscous-turbulent friction parameter ξ. 

Table 5.4: General suggestion for the initial values of the Voellmy friction  
coefficients used for the calibration procedure. 
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with the flow heights and velocities from field observations at the given locations we found 

the following best-fit Voellmy friction coefficients for Dorfbach: 

 

Dry-Coulomb type friction µ [ ] 0.225 

Viscous-turbulent friction ξ [m/s
2
] 130 

 

 

 

 

 

The best-fit Voellmy friction coefficients are now used to perform several simulations (Figure 5.1). 

We performed an additional simulation with a small total volume (5’000 m3) to better model the 

observed flow path. This modification is justified because there are two main locations where depo-

sition was observed during the event of June 7, 2011. One location is out of Figure 5.1 around an 

elevation of 1’730 ma and the second location coincides with location number (3) in the center of the 

channel. The simulation using a total volume of 10’000 and 5’000 m3 show the following flow heights 

and velocities at the two locations 1 and 2: 

 

Table 5.5: Best-fit Voellmy friction coefficients for the case study of Dorfbach, Rand (CH). 

Table 5.6: Resulting maximum flow heights and velocities for total volumes of  
10’000 and 5’000 m

3
 and µ=0.225 and ξ=130 m/s

2
 

Volume: 10’000 m
3 

Max. height [m] Max. velocity [m/s] 

Location 1 2.7 3.8 

Location 2 2.5 2.5 

Volume: 5’000 m
3 

  

Location 1 2.2 2.6 

Location 2 1.1 2 

 

Figure 5.1: Simulations with best-fit parameters µ=0.225 and ξ=130 m/s
2
 for (a) a volume of 10’000 

and (b) 5’000 m
e
 and a DEM resolution of 2m. The dashed line indicates the flow path of the event 

from June 7, 2010. 
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Both simulations with volumes of 10’000 and 5’000 m3 show locations where the flow leaves the 

channel (Figure 5.1, locations 1-2), while in reality the debris flow should simply follow the channel. 

Specifically, these are locations indicated by numbers (1) to (4). A breakout, where the flow left the 

channel, was observed only at location (2) on the orographic right side of the channel. 

These differences might be caused for the following reason: For these simulations we use a resolu-

tion of the DEM (2010) of 2m. Additional simulations using a DEM-resolution of 1m and a volume of 

5’000 m3 could reproduce the flow path at location (1), (3) and (4). At location (2) the outbreak dis-

appeared in the simulation, although it occurred in reality. This result indicates that a resolution of 

2m cannot reproduce the exact flow paths because not all vertical curves are visible on a 2m-DEM 

and therefore material can break out of the channel. The missing outbreak at location (2) for the 2m-

DEM can be explained as following: first, it may indicate that at this location the volume was larger 

than 5’000 m3 and only after location (2) more material was deposited and second, an aspect which 

will be discussed in the next section (5.2), the use of a block release rather than an input hydrograph 

resulted in slightly underestimated flow heights and velocities. 

To conclude, the simulations using a volume of 10’000 m3 indicate a slightly too high volume estima-

tion for the lower part of the torrent. However, to calibrate the Voellmy friction coefficients it was 

still possible to match the flow heights and velocities observed in the field. The small differences in 

the flow path between the simulation and reality can be explained by no ideally resolved terrain. 

  



CHAPTER 5 : APPLICATIONS 

76 

 

5.2 Input hydrograph in comparison with block release 

The following section is based on simulations run in 2011 with RAMMS::DEBRISFLOW v.1.4. 

With an input hydrograph it is possible to constrain inflow of the debris material into the calculation 

domain at a specific location. This is in contrast to a block release simulation where a release area 

with an initial depth is defined for which the entire block of material is accelerated by gravity given 

the frictional resistance, e.g. simulating debris flow initiation as an instantaneous landslide failure. 

Flow depth is a value that can be measured with an observation station or estimated by geomorphic 

evidence. Assuming that the profile and the velocity are known at the measurement location one can 

calculate the discharge hydrograph there. Other options are presented in section 3.5.2. 

5.2.1 Comparison between a block release and an input hydrograph 

Simulations with large volumes and a block release usually have larger maximal discharge values 

(maximum heights) compared to simulations using a hydrograph (Figure 5.2a). The reason is that for 

a block release the release area is defined and the initial release height has to be adjusted according 

to the total volume, specified by the user. This block begins moving as soon as the simulation is 

started. Hence, extremely large and possibly unrealistic initial heights can occur (e.g. we use an initial 

height of 13.2 m for simulations with a total volume of 200’000 m3 at Dorfbach, see studies by Deu-

belbeiss and Graf, 2013). In many cases it would be more reasonable to assume a realistic initial re-

lease height and adjust the release area to match the corresponding total volume. This effect inverts 

for small volumes: the inflow velocity of a hydrograph simulation may be larger than what results 

from a block release simulation at the location of the input hydrograph (Figure 5.2b). The inverse 

effect is also visible in the flow paths (Figure 5.3). The larger flow heights and resulting velocities of a 

block release simulation are represented by the larger extent compared to a hydrograph simulation. 

 

 

 

Figure 5.2: Comparison of discharge curves of a simulation with a block release and a hydrograph 
for (a) a volume of 200’000 m

3
 and (b) a volume of 3’350 m

3
. For all simulations µ=0.225 and ξ=130 

m/s
2
. The discharge curves are measured at the location shown in Figure 5.3. 
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5.2.2 Discussion 

Two general problems appear when comparing the input hydrograph and block release: the friction 

parameters for a large design event may be different than those for the calibration event, and differ-

ences in peak discharge. Large debris flows are often expected to have disproportionally longer 

runout in comparison with smaller flows (e.g. less friction, e.g. smaller µ values). However it is diffi-

cult to generalize about how much the friction parameters should be changed as a function of event 

volume. The situation is further complicated by the observation that very large debris flows tend to 

take place as a series of surges rather than one large surge, and the effective flow topography may 

change due to deposition (or erosion) during the surge. The problem with the unusually large flow 

depths and the input hydrograph was described earlier in this section. Another aspect of that prob-

lem is that sediment entrainment often takes place along the flow path, a process which is NOW 

implemented in RAMMS::DEBRISFLOW. The new erosion module in RAMMS predicts the depth of 

erosion of sediment caused by debris flows. Using this option, it is possible to predict the increase in 

volume of a debris flow as it travels along a channel (see sections 3.5.3 and 5.3). 

5.2.3 Summary 

Using an input hydrograph rather than a block release certainly enhances the simulation results if 

data are available. In this case we can assume that the input parameters are well known and repre-

sent the measured field data (at least at the measurement location). This way large initial release 

heights and the resulting large momenta can be avoided. 

Channelized debris flows, which typically follow a torrent to the runout zone are more accurately 

simulated by input hydrographs. Additionally, the length of the flow path to be simulated can be 

reduced resulting in shorter simulation times. (Be sure the entire hydrograph lies within the calcula-

tion domain.) For hillslope debris flows, which typically occur in open, unchannelized topographies, a 

block release achieves better results. 

  

 

Figure 5.3: Comparison of the inindated areas of a simulation with a vlock release and a hydrograph (a) for a 
volume of 200’000 m

3
 and (b) a volume of 2’250 m

3
. For all simulations µ=0.225 and ξ=130 m/s

2
.  

Blue: hydrograph, red: block release. The red points indicate the location of the measured  
discharge curves (Figure 5.2). 
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5.3 Erosion example 

An example of applying the RAMMS debris-flow erosion algorithm is presented below. In this case 

(Illgraben, Switzerland), channel-bed erosion can only occur between check-dams installed along the 

channel, not at the check dams themselves, so four individual polygons were drawn and included in 

one shape file. The flow is started as a hydrograph (bar-shaped release) and the computational do-

main has been made relatively narrow to decrease computational time. 

Step 1 (not shown): Setup and calibrate RAMMS without considering entrainment. In this case 

RAMMS was calibrated for an example in the literature (Berger et al., 2011) where we know the 

travel time between two of the check dams. The purpose of the first calibration–without erosion–is 

to help narrow-down the choice of the friction parameters µ and  for fine-tuning the model after 

erosion is considered.  

Step 2: Define where erosion can take place. Select the menu option Input –> Polygon shapefile –> 

Draw New Polygon Shapefile and draw the first polygon. After closing the first polygon with a left-

mouse-click, choose the option Add polygon areas, and repeat this procedure until all desired poly-

gons have been drawn. After adding the final polygon (in this case the fourth one) click on the “No” 

button and name the polygon (Figure 5.4). Once this step is completed, the erosion properties within 

this shapefile can be set in a different dialog box (Step 3, Figure 5.5). Although not illustrated here, it 

is possible to create multiple shape files with different erosion parameters within each shape file. 

 
Figure 5.4: Adding erosion polygon areas. 
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Step 3: Set erosion parameters. To set the erosion parameters used during the simulation, select Run 

simulation and then click on the Erosion tab. Click on the folder icon and select the polygon shapefile 

(in this case erodible_bed.shp, Figure 5.5). After selecting the erosion parameters, click on the button 

Add shapefile to list. The default values are proposed, however they can be edited if desired.   

 

One advantage of the new Erosion Module in RAMMS is that the user can start the model with realis-

tic starting conditions, e.g. either a block release (landslide) scenario based on field observations or a 

realistic hydrograph. Then the model will entrain sediment along the flow path, thereby increasing in 

size. The main disadvantage of the new model is that you cannot specify the event volume before 

the simulation starts, because the volume of the debris flow will increase as it entrains sediment 

along the flow path. If precise final volume scenarios are necessary, it may be necessary to run the 

model several times, iteratively adjusting the initial landslide size, until the desired volume is 

achieved (see Frank et al., 2017, for an example). 

 

  

 
Figure 5.5: Erosion parameters. 
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The predicted channel-bed erosion for this case is illustrated in Figure 5.6. Here one can clearly see 

(in comparison with Figure 5.4) that erosion has taken place only within the user-specified polygons 

within the erosion shape file, and not on the check dams separating the individual polygons.   

 

In this case the model was then re-calibrated with small adjustments to the turbulent friction param-

eter, and calibrated (for flow speed) to be within 1 second of observed travel time. A comparison of 

the hydrographs (output from a point placed under the bridge at the top of Figure 5.7, in comparison 

with the flow height measured in the field) illustrates that the steepness of the front, when including 

debris-flow entrainment, is somewhat more realistic. However the case where entrainment is not 

considered is somewhat slower in travel speed, for the same friction parameters.   

 
Figure 5.6: Simulated channel-bed erosion. 
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Figure 5.7: Front steepness comparison; laser data, RAMMS with erosion and RAMMS without erosion. 
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6 Program overview 

RAMMS is a windows-based program that relies on drop-down menus and dialog boxes to set the 

model parameters, run calculations and view results. Toolbar buttons are also available and provide 

short-cuts of the menu paths; moving the cursor over a button results in a short explanation, appear-

ing in a text box below the cursor (‘tooltip’). For functions not available in the current context, the 

menus and buttons are deactivated and cannot be used. 

 

6.1 The Graphical User Interface (GUI) 

The graphical user interface (GUI) (Fig. 6.1) consists of menu bar, horizontal and vertical toolbar, 

main window, time step slider, right and left status bar, colorbar and panel. They will be explained in 

the following sections. 

 

  

 
Figure 6.1: Graphical user interface (GUI) 
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6.1.1 The menu bar 

Track 

Similar to the Microsoft Windows File menu, Track is used to open, close, save, print, backup and 

export files. 

New  Project Wizard Start a new project, guided by the wizard (Ctrl + w)  

 
 Convert XYZ  ASCII 

grid 
Convert (regular) laser scanning data into an ESRI ASCII grid  

 
 Run BATCH simula-

tions 

Possibility to start many simulations automatically (e.g. overnight) 
You can choose how many computational cores the Batch-Mode 
should use (quasi parallel simulations, saves computational time). 

 

 
 Export ASCII Files 

from Simulations 
(Batch) 

Automatically export all ASCII files (max height, max velocity, max 
pressure, deposition) from multiple output files. 

 

Open  Input File Open an existing input file (*.db2) (Ctrl + O)  

 
 Debris Flow Simula-

tion 
Open existing debris flow simulation (*.out.gz) (Ctrl + A).  

Close  Close active file (input or output)  

Save  Save active file (Ctrl + S)  

Save Copy As  
Save a copy of the active file (e.g. test.db2) under a new name 
(e.g. simulation1.db2, works only in input mode). Useful for Batch-
Simulations. 

 

Export  Export Image File 
Create an image of the active window in a chosen format. You can 
choose the desired image format using the file extension (e.g. 
.png, .jpg, .gif, .tif, etc.). 

 

  Export GIF Animation 
Create a GIF animation if the simulation (only in output mode). 
Change GIF animation interval [s] in the preferences.  

Backup 
 Backup RAMMS 

Version 
Make a backup of the current RAMMS Version.  

  Backup Active Project 

Backup your active project. The user will be asked if he wants to 
include output files in the backup. This function is useful when 
having problems with a simulation. Make a backup and send the 
zip-file together with some explanations to ramms@slf.ch. Make 
sure that all your input data (release area shapefiles, domain files, 
etc…) is in the project folder. 

 

 
 Backup User Defined 

Files/Folders 
Backup any folder or files you want.  

Preferences  Change RAMMS preferences  

Log files 
 RAMMS Logfile (cur-

rent) 
Show active RAMMS logfile.  

mailto:ramms@slf.ch
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 RAMMS Logfile (last 

session) 
If RAMMS crashed, open this logfile and copy/paste the content 
into an email to ramms@slf.ch. 

 

Exit  Exit RAMMS (Ctrl + Q).  

 

Edit 

This menu is used to edit colorbar and dataspace properties. 

Colorbar Properties Edit the colorbar properties.  

Get Colorbar Get back your colorbar, if lost.  

Edit Dataspace Properties Edit your dataspace properties.  

Show Dataspace Axes 
Shows or hides dataspace axes of the project region. The axes can only be visible if 
the background color is set to white 

 

Colorbar White Color Checkbox. If checked, the colorbar text-color is white (default), otherwise black.  

 

 

Input 

Menu used to specify the global parameters, the calculation domain, release area, friction parame-

ters and forest cover. This menu is active only in input mode. 

Calculation 
Domain 

 Draw New Calculation 
Domain 

This activates the button to draw a new calculation domain. 
The mouse cursor changes to an arrow.  

  Load Existing Domain 
Load an existing calculation domain (*.dom) drawn and saved 
before. 

 

Polygon  
Shapefile… 

 Draw New  
Polygon Shapefile 

This activates the button to draw new polygon shapefiles. The 
mouse cursor changes to an arrow. Select points with the left 
mouse button, finish with a right mouse button click (the final 
right mouse button click is NOT a point of your polygon). This 
works only in 2D mode. 

 

 
 Load Existing  

Polygon Shapefile 
Load an existing polygon shapefile.  

Release Area 
 Details/Edit Release 

Areas 

The mouse cursor changes to an arrow and you can select 
release area to define the release height and to view release 
area information. This works only in 2D mode 
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Show 

This menu enables and disables the different visualizations. A little arrow indicates if the visualization 

is enabled or disabled. 

Show Lights Show/hide light effects  

Show Grid Show/hide computational grid  

Show Map Show map  

Show Image Show orthophoto/image  

Show Visualization Show/hide release area (input mode) or simulation results (output mode)  

Show Arrow OUTPUT | Show/hide point arrow of time plot  

Show Colorbar Show/hide colorbar  

Show Bottom Color Show/hide 0-color  

Show Velocity Arrow OUTPUT | Show/hide velocity vector  

Show Domain INPUT | Show/hide calculation domain  

 

 

Run 

This menu is active only in input mode. 

Run Calculation 
Opens the Run Simulation window to change parameters and to start the calcula-
tion of a debris flow simulation.  
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Results 

This menu contains the results functions and is only active in output mode. 

Flow Height  Shows flow height of the debris flow every time step.  

Flow Velocity  
Shows flow velocity of the debris flow for every time 
step. 

 

Flow Pressure  
Shows flow pressure of the debris flow for every time 
step. 

 

Flow Momentum  
Shows flow momentum of the debris flow for every 
time step. 

 

Erosion  
Shows flow momentum of the debris flow for every 
time step. 

 

Max Values  Max Flow Height Displays the maximum flow height for each cell.  

  Max Velocity Displays the maximum velocity for each cell.  

  Max Pressure Displays the maximum pressure for each cell.  

  Max Flow Momentum Displays the maximum momentum for each cell.  

  Max Shear Stress Displays the maximum shear stress for each cell.  

  Max Erosion Displays the maximum erosion depth for each cell.  

Add Deposition to DEM  
Adds the deposition of a debris flow simulation to a 
new DEM. 

 

Summary of Moving Mass  Summarizes the Moving Mass.  

Mu  Displays the friction parameter µ for this simulation.  

Xi  Display the friction parameter ξ for this simulation.  

Grid Cell Area  Display the grid cell area for each cell (m
2
).  
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GIS 

This menu contains GIS functions. 

Add Data  
Add data (shapefiles, MuXi-ASCII files) to the visualiza-
tion. 

 

Export …  Results As Shapefile 
Export the active result to an ESRI GIS shapefile for 
later use in a GIS program. 

 

  Results As ASCII Grid Displays the maximum velocity for each cell.  

  Envelope Shapefile Create an envelope shapefile from the active result.  

 
 Envelope Shapefile from 

ASCII File 
Create an envelope shapefile from an ASCII file. User 
can specify an ASCII file (e.g. max flow height). 

 

Add Dam to DEM 
Adds a dam to the DEM. You have to specify rel-
ative dam height or absolute dam elevation. 

 

Show Slope Angle (°) Display the slope angles.  

Show Curvature (1/m) Display the curvatures.  

Show Contour Plot Display a contour plot.  

Resample Slope/Curvature 
Normally, slope an curvature are calculated for a 
grid resolution of 10m. You can change this reso-
lution by using this function. 
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Extras 

Add/Change or Remove map 

Add or change the topographic map of your pro-
ject. The maps can be located in your project di-
rectory, or in your distribution’s ‘Map’ folder, 
see section Fehler! Verweisquelle konnte nicht 
gefunden werden. for details. If not, you can 
browse for the maps. 

 

Add/Change or Remove Im-
ager 

Add, change or remove the image used for visu-
alization of your project. The images can be lo-
cated in your project directory, or in your distri-
bution’s ‘IMAGE’ folder, see section Fehler! 
Verweisquelle konnte nicht gefunden werden. 
for details. If not, you can browse for images. 

 

Point …  Choose Interactively 
This activates the button to select a point. The mouse 
cursor changes to an arrow. Select the point with the 
left mouse button. This works only in 2D mode. 

 

  Enter Coordinates (X/Y) Enter the coordinates of a point you are interested in.  

  Create Time Plot Create a time plot of a selected point.  

  View Info File View point info file.  

  Save Point Location Save point location as a point shapefile.  

  Export Time Plot Data Export time plot data as a txt-file.  

Profile …  Draw New Line Profile 

This activates the button to draw a line profile. The 
mouse cursor changes to an arrow. Select the points of 
the line profile with the left mouse button, finish with 
a right mouse click. This works only in 2D mode. 

 

  Save Line Profile Points Save your line profile as a polyline shapefile.  

 
 Export Line Profile Plot 

Data 
Export the line profile plot data as a txt-file.  

Save Active Position 
Save your current state of view, as well as the 
enabled and disabled visualizations. 

 

Reload Position Reload your saved position.  

Google Earth … 
 Export Result to Google 

Earth 

This function exports release areas and your results to 
Google Earth. If your project location is within Switzer-
land (default), you can use this function without 
changing any options. If not, see Map Options. 
 

 

  Map Options 
Enter map options if you want to export your result 
from a location outside of Switzerland 

 

  Map Options Help Get help about Google Earth Map Options.  

View input file Opens the input file in a window.  

View Simulation Standard 
Output Log 

Opens the simulations standard output log in a 
window (the black DOS window you see when a 
simulation is running). 
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Project 

This menu contains the project input and output logfiles. 

Input Log File Displays the input logfile.  

Output Log File Displays the output logfile. The input logfile is appended to the output logfile.  

Open Project Folder (Windows 
Explorer) 

Opens project Folder in Window Explorer from within RAMMS.  

 

 

Help 

RAMMS User Manual (pdf)  RAMMS User Manual in pdf format. 

Friction Parameter Table 
(pdf) 

 Table of MuXi friction values in pdf format. 

License Agreement  RAMMS License Agreement 

RAMMS Homepage  
Opens the RAMMS homepage at http://ramms.slf.ch 
in a web browser. 

Update...  
Download RAMMS updates manually or directly from 
the web. 

Update…  Web Update 
Start web update procedure. RAMMS checks online if 
there is an update available. 

 
 Get Update Manually 

(download to local folder) 
Download the update to a local folder. 

 
 Install Update from local 

folder 
Install the update from a local folder. 

Register New RAMMS 

Module 
 Register your new RAMMS::DEBRIS FLOW license here. 

Advanced… 
 Color Tables – View Avail-

able Color Tables 
Choose a different type of color scheme for your 
colorbar. 

 
 Additional Preferences - 

Edit 
Only for experts. Please contact ramms@slf.ch if you 
have questions about the additional preferences. 

  Reset General Preferences 
Reset your general preferences (working directory, 
map directory etc.). 

  Install C++ Libraries 

It is possible, that the Visual C++ Redistributable librar-
ies for Visual Studio 2015 (x64) are not installed on 
your PC/laptop. These libraries are needed to run 
RAMMS. In case they are missing, you are not able to 
run simulations. Run this function to install these 
libraries. 

  Logging Checkbox. Switch logging on or off. 
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  AutoWebUpdate 

Checkbox. Switch AutoWebUpdate on or off. If Au-
toWebUpdate is on, then RAMMS will check for up-
dates whenever you start RAMMS. 
 

  Hardware Rendering 

Checkbox. Switch hardware rendering on or off. If 
hardware rendering is switched on, then all graphical 
rendering is done by your hardware, otherwise by IDL 
(RAMMS). It is suggested to switch hardware rendering 
on. 
 

  Curvature 

Checkbox. Switch curvature on or off. See section 
Fehler! Verweisquelle konnte nicht gefunden werden. 
n page Fehler! Textmarke nicht definiert. for more 
information about curvature. 
 

 
 Technical Support Infor-

mation 

If you have a problem using RAMMS, please send us 
the information from the Technical Support Infor-
mation together with any error screenshots from 
RAMMS. 

RAMMS Changelog  Information about the RAMMS releases in pdf format. 

About RAMMS  About RAMMS information 
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6.1.2 Horizontal toolbar 

 
Project wizard: open debris flow wizard for creating a new debris flow project. (Ctrl + W) 

 
Open input file. (Ctrl + O) 

 
Open simulation. (Ctrl + A) 

 
INPUT | Save copy as: save the active file under a new name. 

 
INPUT and OUTPUT | Close: close the active file. 

 
Print: displays the Windows print manager. 

 
Undo, Redo. 

 
Arrow (move and resize), Rotate, Move. 

 

Simulation Results: Choose this function and move the arrow over the topography  x-, 
y- and z-Coordinates of the mouse position are shown in the lower right status bar (see 

Figure 6.11 on page 100). 

 

OUTPUT | If you move the arrow over the simulation data, the active parameter is 
shown as well (see right value in the figure below). If you click once with the left mouse 
button at a point of interest, a new window pops up called ‘RAMMS::DEBRISFLOW Time 
Plot <Active Parameter>’. 

 

INPUT, 2D | Draw new polygon shapefile: specify new polygon-points by clicking the left 
mouse button, finish with a right mouse click. The user is asked if he wants to draw 
more polygons. At last, he has to specify a new filename for the polygon shapefile. 

 

INPUT, 2D |Create new domain area: specify a new domain polygon by clicking with left 
mouse button, for the last polygon-point click the right mouse button to finish. A dialog 
box will then ask the user for a new domain name (e.g. test). 

 

OUTPUT, 2D | Line Profile: Select the topography, until the Line-Profile-Button is active. 
Click the button and then move the cursor to the start point of your profile. Click the left 
mouse button and move the cursor to the next position of your profile. At the end posi-
tion of your profile click the right mouse button. A new window pops up called 
‘RAMMS::DEBRISFLOW Line Profile Plot Active Parameter’. This line profile plot is linked 
to your simulation. If you change the parameter or if you change the max-value in the 
debris flow panel, the changes are adapted in the line profile plot! 

 
INPUT, 2D | View and Edit Release Areas. 

 
Zoom tools. 

 

Annotation tools, text, line, rectangle, oval, polygon, freehand. They can be activated 
and deactivated in the additional preferences. 

Preferences  Advanced…  Edit  Annotations 

 
Interpretation of the input DEM: Slope Angle, Curvature and Contour Plots. Remove 
visualization by clicking the button again. 
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OUTPUT | Show Maximum values of the simulation results: Max. Flow Height, Max. 
Flow Velocity and Max. Pressure. 

 
OUTPUT, 2D |create a time plot for the last point location. 

 
OUTPUT | export the results to ASCII grid. 

 
Open project folder in Windows Explorer. 

 
Add/change maps/orthophotos. 
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6.1.3 Vertical Toolbar 

 
Add shapefile (*.shp). 

 
Switch to input file of an already open simulation. 

 
Show/hide lights. 

 
Show/hide mesh. 

 
INPUT | Show/hide release area (or active parameter). 

 OUTPUT | show/hide simulation. 

 
Show/hide colorbar. 

 
OUTPUT | Show/hide velocity vector arrow. 

 
Show map. 

 
Show image. 

 
INPUT | Run Simulation. 

 

OUTPUT | Animate Simulation / Continue Simulation. 

 Stop/Pause Simulation ( ). 

 
OUTPUT | End Simulation: skip to last dump-step of simulation. 

 
Create a screenshot of the main window. 

 
OUTPUT | Create GIF animation. 

 
Change RAMMS Additional Preferences. 

 
Edit dataspace properties. 

 
Change RAMMS preferences (e.g. working directory). 

 Change view to 2D / Change view to 3D (  ). 

 Refresh visualization (if stuck). 

 

  



CHAPTER 7 : REFERENCES AND FURTHER READING 

94 

 

6.1.4 Main window 

The RAMMS GUI (Graphical User Interface) consists of two main regions, see Figure 6.2:  

1. Main visualization window 
2. Information panel, see section below. 

  

 
Figure 6.2: RAMMS GUI. 

 

2 

1 
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6.1.5 Panel 

A DEBRIS FLOW panel is displayed on the right side of the RAMMS GUI (Figure 6.2), and consists of 

five tabs (Files, General, Display, Volumes and Region).  

 

Files tab 

The Files tab (Figure 6.3) shows a file tree with nodes for polygon shapefiles (Polygon, *.shp) and 

calculation domain files (Domain, *.shp). See section 3.4.1 on page 25 on how to use the Files tab. 

  

 
Figure 6.3: Debris flow panel – Files tab 
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General tab 

The General tab (Figure 6.4) shows important simulation parameters, such as: nr. of nodes, nr. of 

cells, end time (s), dump-step (s), grid resolution (m) and density (kg/m3). In input mode, for handling 

and visualization purposes, the topographic information is resampled, such that there are only ca. 

50’000 grid cells remaining (see Visualization Resampling Remarks in Figure 6.4, red box). This does 

not influence any simulation at all, it simply makes the users life easier to zoom and rotate the topog-

raphy. 

 

  

  
Figure 6.4: Debris flow panel – General tab 
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Display tab 

The Display tab (Figure 6.5) shows parameters that are important for the display of results and poly-

gon shapefiles, such as Min_Value, Max_Value, Nr_of_Colors and Transparency. Always confirm with 

ENTER (return key) when changing a value! Additionally, the PARAMETER line states the visible pa-

rameter (e.g. Flow height (m) in Figure 6.5, red box). 

 

The min and max values as well as the number of colors influence directly the colorbar and the visu-

alization. The transparency of the simulation results can be changed on the debris flow panel, tab 

display. 0% means no transparency, 100% means total transparency, see figure below (Figure 6.6). 

The colorbar is divided into n (nr. of colors) different colors, where the lowest color is normally not 

displayed. The bottom line informs the user of the range of values that are not displayed in the cur-

rent visualization (only in output mode). 

 

  
Figure 6.5:  Debris flow panel – Display tab 

 
Figure 6.6: No transparency (left) and 40% transparency (right) of simulation result. 
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Volumes tab 

The Volumes tab (Figure 6.7) gives the user information about  

 projected release area (m2)  

 inclined (3D) release area (m2) 

 release volume (m3, estimated in input mode)  

 release mass (t, input) / flow volume (m3, output) 

 

 

 

 

  

  
Figure 6.7: Debris flow panel – Volumes tab 
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Region tab 

The region tab (D) gives information about min and max X-, Y-coordinates and the altitude limits as 

well as information about the region area in km2. 

 

 

6.1.6 Time step slider 

The time step slider can be moved manually to change the active time step (only in output mode). 

 

6.1.7 Left status bar 

The left status bar is used to display status information for operations or informational messages 

pertaining to the currently selected surface or manipulators. 

 

 

 

 

 
Figure 6.8: Debris flow panel – Region tab 

 

Figure 6.9:  The active time (20s) is shown in the time slider . 

 
Figure 6.10: Status information shown in the left status bar. 
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6.1.8 Right status bar 

The right status bar is used to display the position of the cursor within the surface and additional 

simulation results at the position of the cursor. 

 

6.1.9 Colorbar 

In general, the colorbar appears at the right 

edge of the main window (Fig. 6.1) and can 

be moved and resized (see section 3.4.4 on 

page 30).  

 

 

  

 
Figure 6.11: Position information and triangle simulation results in the right status bar. 

 
Figure 6.12: Colorbar 
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7.2 Publications 

The development of RAMMS is based on scientific findings published in international scientific 

journals. A list of the most important scientific publications about RAMMS and its applications 

can be found on our homepage at http://ramms.slf.ch, section RESOURCES-Publications. 

  

http://ramms.slf.ch/
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Third-Party Software 

The following third-party software components are used in RAMMS: 

7-zip: 

 We sometimes use 7za.exe to zip data. 

 7-zip is licensed under GNU LGPL. 

 The source code of 7-zip is available at www.7-zip.org. 

Mtee: 

 Mtee is a Win32 console application that sends any data it receives to stdout and to any 

number of files. 

 Mtee is released under MIT License https://ritchielawrence.github.io/mtee/. 

 

  

http://www.7-zip.org/
https://ritchielawrence.github.io/mtee/
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